source: npl/overig/google_perftools/google_perftools.SlackBuild @ 7ca52c9

Last change on this file since 7ca52c9 was 4e011a4, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

voor kopano

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10
11
12#######Essential package info.
13#Change these if autodetection fails.
14
15#Name of the Syn-3 package that we are going to create
16NAME=`basename $0|sed 's/.SlackBuild//'`
17
18#Archive of the sourcefiles to unpack
19SRC_ARC=`ls *.tar.*`
20
21#Version of the sourcefiles
22VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
23
24#Directory of the sourcefiles to build (after optional unpacking)
25SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
26
27#Architecture that the created binaries run on.
28#Use noarch for scripts.
29ARCH=`uname -m`
30
31
32########Build and create the pacakge.
33#Uncomment the stuff that you dont want or need
34
35#Unpack source
36#(uncomment if not needed)
37syn3_unpack $SRC_ARC || exit 1
38
39#apply patches
40#patch -p1 -d $SRC_DIR < libical-0.23-zarafa.patch || exit 1
41#patch -p1 -d $SRC_DIR < libical-0.23-zarafa.patch || exit 1
42
43#build and install sourcefiles
44#./configure optiones:
45export CONFIGURE_OPTS=""
46#options for all make commands:
47#export MAKE_OPTS="-j1"
48#skip testing:
49export NOTEST=1
50#extra optiones for the make install command, use with INSTALL_BASE for example:
51export INSTALL_OPTS=""
52syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
53
54#strip bins and other stuff
55syn3_strip /tmp/pkg || exit 1
56
57#move development stuff and create seperate development package
58syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
59syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
60
61#make main package
62syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
63
64
Note: See TracBrowser for help on using the repository browser.