gcc484ntopperl-5.22
Last change
on this file since 1393bb5 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
667 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | ROOT=`pwd` |
---|
| 3 | PACKAGE=gperf |
---|
| 4 | VERSION=3.0.2 |
---|
| 5 | PKGROOT=/tmp/tar |
---|
| 6 | |
---|
| 7 | mkdir $PKGROOT -p |
---|
| 8 | tar -xzf $PACKAGE-$VERSION.tar.gz ||exit 1 |
---|
| 9 | cd $PACKAGE-$VERSION ||exit 1 |
---|
| 10 | |
---|
| 11 | ./configure --prefix=/usr ||exit 1 |
---|
| 12 | make ||exit 1 |
---|
| 13 | make -j1 check ||exit 1 |
---|
| 14 | make install DESTDIR=$PKGROOT ||exit 1 |
---|
| 15 | |
---|
| 16 | cd $PKGROOT ||exit 1 |
---|
| 17 | # Strip binaries: |
---|
| 18 | ( cd $PKGROOT |
---|
| 19 | find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
| 20 | find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip -g 2> /dev/null |
---|
| 21 | ) |
---|
| 22 | |
---|
| 23 | makepkg -l y -c n $ROOT/$PACKAGE.pkg > /dev/null && |
---|
| 24 | echo $VERSION > $ROOT/$PACKAGE.version && |
---|
| 25 | arch > $ROOT/$PACKAGE.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.