source: npl/overig/gpxe/gpxe.SlackBuild @ 072d3d5

gcc484perl-5.22
Last change on this file since 072d3d5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies
8#Our package will be automaticly rebuilded if there is a major change in a DEP package.
9#(this is recommended for most dependencys)
10##DEP:linux
11##DEP:linux_src
12##DEP:openldap
13
14#Loose build-dependencies
15#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
16#(not recommended)
17##NEED:doxygen
18
19#######Essential package info.
20#Change these if autodetection fails.
21
22#Name of the Syn-3 package that we are going to create
23NAME=`basename $0|sed 's/.SlackBuild//'`
24
25#Archive of the sourcefiles to unpack
26SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
27
28#Version of the sourcefiles
29VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
30
31#Architecture that the created binaries run on.
32#Use noarch for scripts.
33ARCH=`uname -m`
34
35#from this point on, exit on errors:
36set -e
37
38########Build and create the pacakge.
39#Uncomment the stuff that you dont want or need
40
41#Unpack source
42#(uncomment if not needed)
43syn3_unpack $SRC_ARC
44
45#Directory where the sourcefiles are unpacked.
46#(you might have to adjust this if autodetection fails)
47SRC_DIR=`ls -c|head -1`
48
49#apply patches
50#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
51
52CWD=`pwd`
53pushd $SRC_DIR
54cd src
55 
56sed 's/#undef.*COMPRESERVE/#define COMPRESERVE/g' -i config/serial.h
57sed 's@//#define.*CONSOLE_SERIAL@#define CONSOLE_SERIAL@g' -i config/console.h
58
59
60make EMBEDDED_IMAGE=$CWD/boot.gpxe bin/undionly.kpxe
61
62mkdir -p /tmp/pkg/home/shares/tftp
63cp bin/undionly.kpxe /tmp/pkg/home/shares/tftp/gpxe.0
64
65
66
67
68popd
69
70#make main package
71syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
72
73
74
Note: See TracBrowser for help on using the repository browser.