source: npl/overig/graphviz/graphviz.SlackBuild @ 9befa48

Last change on this file since 9befa48 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:gd
8#DEP:freetype2
9#DEP:libpng
10#DEP:libjpeg
11#DEP:bzip2
12#DEP:zlib
13#DEP:libtool
14
15#######Essential package info.
16#Change these if autodetection fails.
17
18#Name of the Syn-3 package that we are going to create
19NAME=`basename $0|sed 's/.SlackBuild//'`
20
21#Archive of the sourcefiles to unpack
22SRC_ARC=`ls *.tar.*`
23
24#Version of the sourcefiles
25VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
26
27#Directory of the sourcefiles to build (after optional unpacking)
28SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
29
30#Architecture that the created binaries run on.
31#Use noarch for scripts.
32ARCH=`uname -m`
33
34
35########Build and create the pacakge.
36#Uncomment the stuff that you dont want or need
37
38#Unpack source
39#(uncomment if not needed)
40syn3_unpack $SRC_ARC || exit 1
41
42#apply patches
43#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
44
45#build and install sourcefiles
46#./configure optiones:
47export CONFIGURE_OPTS=""
48#options for all make commands:
49export MAKE_OPTS=""
50#skip testing:
51export NOTEST=1
52#extra optiones for the make install command, use with INSTALL_BASE for example:
53export INSTALL_OPTS=""
54syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
55
56#strip bins and other stuff
57syn3_strip /tmp/pkg || exit 1
58
59#postinst
60mkdir -p /tmp/pkg/etc/postinst.d
61cp post.graphviz /tmp/pkg/etc/postinst.d || exit 1
62chmod +x /tmp/pkg/etc/postinst.d/* || exit 1
63
64#move development stuff and create seperate development package
65syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
66syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
67
68#make main package
69syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
70
71
Note: See TracBrowser for help on using the repository browser.