1 | #!/bin/sh |
---|
2 | |
---|
3 | # Copyright 2005-2008, 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA |
---|
4 | # All rights reserved. |
---|
5 | # |
---|
6 | # Redistribution and use of this script, with or without modification, is |
---|
7 | # permitted provided that the following conditions are met: |
---|
8 | # |
---|
9 | # 1. Redistributions of this script must retain the above copyright |
---|
10 | # notice, this list of conditions and the following disclaimer. |
---|
11 | # |
---|
12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
22 | |
---|
23 | |
---|
24 | PKGNAM=groff |
---|
25 | VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} |
---|
26 | BUILD=${BUILD:-1} |
---|
27 | |
---|
28 | # Automatically determine the architecture we're building on: |
---|
29 | if [ -z "$ARCH" ]; then |
---|
30 | case "$( uname -m )" in |
---|
31 | i?86) export ARCH=i486 ;; |
---|
32 | arm*) export ARCH=arm ;; |
---|
33 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
34 | *) export ARCH=$( uname -m ) ;; |
---|
35 | esac |
---|
36 | fi |
---|
37 | |
---|
38 | NUMJOBS=${NUMJOBS:--j7} |
---|
39 | |
---|
40 | CWD=$(pwd) |
---|
41 | TMP=${TMP:-/tmp} |
---|
42 | PKG=$TMP/package-groff |
---|
43 | |
---|
44 | if [ "$ARCH" = "i486" ]; then |
---|
45 | SLKCFLAGS="-O2 -march=i486 -mtune=i686" |
---|
46 | LIBDIRSUFFIX="" |
---|
47 | elif [ "$ARCH" = "s390" ]; then |
---|
48 | SLKCFLAGS="-O2" |
---|
49 | LIBDIRSUFFIX="" |
---|
50 | elif [ "$ARCH" = "x86_64" ]; then |
---|
51 | SLKCFLAGS="-O2 -fPIC" |
---|
52 | LIBDIRSUFFIX="64" |
---|
53 | else |
---|
54 | SLKCFLAGS="-O2" |
---|
55 | LIBDIRSUFFIX="" |
---|
56 | fi |
---|
57 | |
---|
58 | rm -rf $PKG |
---|
59 | mkdir -p $TMP $PKG |
---|
60 | |
---|
61 | cd $TMP |
---|
62 | rm -rf groff-$VERSION |
---|
63 | tar xvf $CWD/groff-$VERSION.tar.?z* || exit 1 |
---|
64 | cd groff-$VERSION || exit 1 |
---|
65 | chown -R root:root . |
---|
66 | find . \ |
---|
67 | \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ |
---|
68 | -exec chmod 755 {} \; -o \ |
---|
69 | \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ |
---|
70 | -exec chmod 644 {} \; |
---|
71 | |
---|
72 | CFLAGS="$SLKCFLAGS" \ |
---|
73 | CXXFLAGS="$SLKCFLAGS" \ |
---|
74 | ./configure \ |
---|
75 | --prefix=/usr \ |
---|
76 | --libdir=/usr/lib${LIBDIRSUFFIX} \ |
---|
77 | --mandir=/usr/man \ |
---|
78 | --infodir=/usr/info \ |
---|
79 | --docdir=/usr/doc/groff-$VERSION \ |
---|
80 | --build=$ARCH-slackware-linux |
---|
81 | |
---|
82 | make $NUMJOBS || make || exit 1 |
---|
83 | make install DESTDIR=$PKG |
---|
84 | |
---|
85 | find $PKG | xargs file | grep -e "executable" -e "shared object" \ |
---|
86 | | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
87 | |
---|
88 | ( cd src/devices/xditview |
---|
89 | mkdir -p $PKG/etc/X11/app-defaults |
---|
90 | cp -a GXditview.ad $PKG/etc/X11/app-defaults/GXditview |
---|
91 | ) |
---|
92 | |
---|
93 | cp -a \ |
---|
94 | BUG-REPORT COPYING* ChangeLog FDL INSTALL* LICENSES MANIFEST MORE.STUFF \ |
---|
95 | NEWS PROBLEMS PROJECTS README* REVISION TODO VERSION \ |
---|
96 | $PKG/usr/doc/groff-$VERSION |
---|
97 | mkdir -p $PKG/usr/doc/groff-$VERSION/xditview |
---|
98 | cp -a src/devices/xditview/{README,TODO} $PKG/usr/doc/groff-$VERSION/xditview |
---|
99 | |
---|
100 | # If there's a ChangeLog, installing at least part of the recent history |
---|
101 | # is useful, but don't let it get totally out of control: |
---|
102 | if [ -r ChangeLog ]; then |
---|
103 | DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION) |
---|
104 | cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog |
---|
105 | touch -r ChangeLog $DOCSDIR/ChangeLog |
---|
106 | fi |
---|
107 | |
---|
108 | # If you want all this stuff, it's in the source tarball: |
---|
109 | rm -rf $PKG/usr/doc/groff-$VERSION/*.ps \ |
---|
110 | $PKG/usr/doc/groff-$VERSION/examples \ |
---|
111 | $PKG/usr/doc/groff-$VERSION/html \ |
---|
112 | $PKG/usr/doc/groff-$VERSION/pdf |
---|
113 | |
---|
114 | ( cd $PKG/usr/man |
---|
115 | find . -type f -exec gzip -9 {} \; |
---|
116 | for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done |
---|
117 | ) |
---|
118 | |
---|
119 | rm -f $PKG/usr/info/dir |
---|
120 | gzip -9 $PKG/usr/info/* |
---|
121 | |
---|
122 | # Do not use color ANSI output by default for man pages. |
---|
123 | # A silly "innovation" if ever there was one, sure to break |
---|
124 | # a ton of existing scripts otherwise... |
---|
125 | zcat $CWD/groff.man.mdoc.local.gz >> $PKG/usr/share/groff/site-tmac/man.local |
---|
126 | zcat $CWD/groff.man.mdoc.local.gz >> $PKG/usr/share/groff/site-tmac/mdoc.local |
---|
127 | |
---|
128 | ( cd $PKG/usr/bin |
---|
129 | rm -rf geqn ; ln -sf eqn geqn |
---|
130 | rm -rf gindxbib ; ln -sf indxbib gindxbib |
---|
131 | rm -rf gpic ; ln -sf pic gpic |
---|
132 | rm -rf grefer ; ln -sf refer grefer |
---|
133 | rm -rf gsoelim ; ln -sf soelim gsoelim |
---|
134 | rm -rf zsoelim ; ln -sf soelim zsoelim |
---|
135 | rm -rf gtbl ; ln -sf tbl gtbl |
---|
136 | rm -rf gtroff ; ln -sf troff gtroff |
---|
137 | rm -rf glookbib ; ln -sf lookbib glookbib |
---|
138 | rm -rf gnroff ; ln -sf nroff gnroff |
---|
139 | rm -rf gneqn ; ln -sf neqn gneqn |
---|
140 | ) |
---|
141 | |
---|
142 | mkdir -p $PKG/install |
---|
143 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
144 | |
---|
145 | cd $PKG |
---|
146 | /sbin/makepkg -l y -c n $TMP/groff-$VERSION-$ARCH-$BUILD.txz |
---|
147 | |
---|