source: npl/overig/gsoap/gsoap.SlackBuild @ ffaaf60

Last change on this file since ffaaf60 was 4e011a4, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

voor kopano

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2
3#DEP:openssl
4#DEP:zlib
5
6#######Essential package info.
7#Change these if autodetection fails.
8
9#Name of the Syn-3 package that we are going to create
10NAME=`basename $0|sed 's/.SlackBuild//'`
11
12#Archive of the sourcefiles to unpack
13SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
14
15#Version of the sourcefiles
16VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
17
18#MOET 2.8.22 blijven voor zarafa blijkbaar..
19VER=2.8.47
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25#from this point on, exit on errors:
26set -e
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40patch -p1 -d $SRC_DIR < nofastopen.patch || exit 1
41
42pushd $SRC_DIR
43
44#AUTOMAKE: Configure
45#Some usefull stuff you sometimes need to set:
46#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
47#export LD_LIBRARY_PATH=/usr/lib/mysql
48#export VPATH=$LD_LIBRARY_PATH
49#export CFLAGS="-std=c89"
50#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
51MAKE_OPTS="-j1"
52./configure --prefix=/usr  || exit 1
53
54#AUTOMAKE: Compile
55make $MAKE_OPTS || exit 1
56
57#AUTOMAKE: Test (optional)
58if grep ^test: Makefile; then
59        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
60        make $MAKE_OPTS test || exit 1
61elif grep ^check: Makefile; then
62        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
63        make $MAKE_OPTS check || exit 1
64fi
65
66#AUTOMAKE: Install
67mkdir -p /tmp/pkg &>/dev/null
68make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
69popd
70
71#strip bins and other stuff
72syn3_strip /tmp/pkg || exit 1
73
74#move development stuff and create seperate development package
75syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
76syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
77
78#make main package
79syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
80
81
82
Note: See TracBrowser for help on using the repository browser.