source: npl/overig/guile/guile.SlackBuild.orig @ 1393bb5

gcc484ntopperl-5.22
Last change on this file since 1393bb5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.8 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2013  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=guile
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-2}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i486 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40CWD=$(pwd)
41TMP=${TMP:-/tmp}
42PKG=$TMP/package-guile
43rm -rf $PKG
44mkdir -p $PKG/usr
45
46if [ "$ARCH" = "i486" ]; then
47  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
48  LIBDIRSUFFIX=""
49elif [ "$ARCH" = "s390" ]; then
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52elif [ "$ARCH" = "x86_64" ]; then
53  SLKCFLAGS="-O2 -fPIC"
54  LIBDIRSUFFIX="64"
55else
56  SLKCFLAGS="-O2"
57  LIBDIRSUFFIX=""
58fi
59
60cd $TMP
61rm -rf guile-$VERSION
62tar xvf $CWD/guile-$VERSION.tar.xz || exit 1
63cd guile-$VERSION || exit 1
64chown -R root:root .
65find . \
66  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67  -exec chmod 755 {} \; -o \
68  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69  -exec chmod 644 {} \;
70
71CFLAGS="$SLKCFLAGS" \
72./configure \
73  --prefix=/usr \
74  --libdir=/usr/lib${LIBDIRSUFFIX} \
75  --infodir=/usr/info \
76  --mandir=/usr/man \
77  --with-threads \
78  --disable-static \
79  --disable-rpath \
80  --disable-error-on-warning \
81  --build=$ARCH-slackware-linux
82
83# Does not like parallel make...
84make $NUMJOBS || make || exit 1
85make install DESTDIR=$PKG || exit 1
86
87# Move libguile*-gdb.scm to GDB's autoload directory to avoid
88# getting "not an ELF file" errors from ldconfig:
89mkdir -p $PKG/usr/share/gdb/auto-load/usr/lib${LIBDIRSUFFIX}
90mv $PKG/usr/lib${LIBDIRSUFFIX}/libguile*-gdb.scm $PKG/usr/share/gdb/auto-load/usr/lib${LIBDIRSUFFIX} || exit 1
91
92find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
93  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
94
95# Compress and link manpages, if any:
96if [ -d $PKG/usr/man ]; then
97  ( cd $PKG/usr/man
98    for manpagedir in $(find . -type d -name "man*") ; do
99      ( cd $manpagedir
100        for eachpage in $( find . -type l -maxdepth 1) ; do
101          ln -s $( readlink $eachpage ).gz $eachpage.gz
102          rm $eachpage
103        done
104        gzip -9 *.?
105      )
106    done
107  )
108fi
109
110# Compress info files, if any:
111if [ -d $PKG/usr/info ]; then
112  ( cd $PKG/usr/info
113    rm -f dir
114    gzip -9 *
115  )
116fi
117
118mkdir -p $PKG/usr/doc/guile-$VERSION
119cp -a \
120  AUTHORS COPYING* GUILE-VERSION \
121  HACKING INSTALL LICENSE NEWS README* THANKS \
122  $PKG/usr/doc/guile-$VERSION
123
124mkdir -p $PKG/install
125cat $CWD/slack-desc > $PKG/install/slack-desc
126
127cd $PKG
128/sbin/makepkg -l y -c n $TMP/guile-$VERSION-$ARCH-$BUILD.txz
129
Note: See TracBrowser for help on using the repository browser.