source: npl/overig/htmldoc/htmldoc.SlackBuild @ a9c55d3

perl-5.22
Last change on this file since a9c55d3 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:libjpeg
22#DEP:libpng
23#DEP:zlib
24
25#######Essential package info.
26#Change these if autodetection fails.
27
28#Name of the Syn-3 package that we are going to create
29NAME=`basename $0|sed 's/.SlackBuild//'`
30
31#Archive of the sourcefiles to unpack
32SRC_ARC=`ls *.tar.*`
33
34#Version of the sourcefiles
35VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
36
37#Directory of the sourcefiles to build (after optional unpacking)
38SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
39
40#Architecture that the created binaries run on.
41#Use noarch for scripts.
42ARCH=`uname -m`
43
44
45########Build and create the pacakge.
46#Uncomment the stuff that you dont want or need
47
48#Unpack source
49#(uncomment if not needed)
50syn3_unpack $SRC_ARC || exit 1
51
52#apply patches
53#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
54
55#build and install sourcefiles
56#./configure optiones:
57export CONFIGURE_OPTS=""
58#options for all make commands:
59export MAKE_OPTS=""
60#skip testing:
61#export NOTEST=1
62#extra optiones for the make install command, use with INSTALL_BASE for example:
63export INSTALL_OPTS="bindir=/tmp/pkg/usr/bin prefix=/tmp/pkg/usr"
64syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
65
66#strip bins and other stuff
67syn3_strip /tmp/pkg || exit 1
68
69#move development stuff and create seperate development package
70syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
71syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
72
73#make main package
74syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
75
76
Note: See TracBrowser for help on using the repository browser.