source: npl/overig/htop/htop.SlackBuild.orig @ cd8630b

gcc484perl-5.22
Last change on this file since cd8630b was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.6 KB
Line 
1#!/bin/sh
2
3# Copyright 2011, 2016  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=htop
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i586" ]; then
41  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-$PKGNAM
57
58rm -rf $PKG
59mkdir -p $TMP $PKG
60
61cd $TMP
62rm -rf $PKGNAM-$VERSION
63tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
64cd $PKGNAM-$VERSION
65chown -R root:root .
66find . \
67  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
68  -exec chmod 755 {} \; -o \
69  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
70  -exec chmod 644 {} \;
71
72CFLAGS="$SLKCFLAGS" \
73./configure \
74  --prefix=/usr \
75  --sysconfdir=/etc \
76  --libdir=/usr/lib${LIBDIRSUFFIX} \
77  --mandir=/usr/man \
78  --docdir=/usr/doc/$PKGNAM-$VERSION \
79  --disable-static \
80  --build=$ARCH-slackware-linux
81
82make $NUMJOBS || make || exit 1
83make install DESTDIR=$PKG || exit 1
84
85find $PKG | xargs file | grep -e "executable" -e "shared object" \
86  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
87
88# Compress and link manpages, if any:
89if [ -d $PKG/usr/man ]; then
90  ( cd $PKG/usr/man
91    for manpagedir in $(find . -type d -name "man*") ; do
92      ( cd $manpagedir
93        for eachpage in $( find . -type l -maxdepth 1) ; do
94          ln -s $( readlink $eachpage ).gz $eachpage.gz
95          rm $eachpage
96        done
97        gzip -9 *.?
98      )
99    done
100  )
101fi
102
103# Install documentation:
104mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
105cp -a \
106  AUTHORS COPYING* NEWS README*  \
107  $PKG/usr/doc/$PKGNAM-$VERSION
108
109# If there's a ChangeLog, installing at least part of the recent history
110# is useful, but don't let it get totally out of control:
111if [ -r ChangeLog ]; then
112  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
113  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
114  touch -r ChangeLog $DOCSDIR/ChangeLog
115fi
116
117mkdir -p $PKG/install
118cat $CWD/slack-desc > $PKG/install/slack-desc
119
120cd $PKG
121/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
122
Note: See TracBrowser for help on using the repository browser.