perl-5.22
Last change
on this file since 34a7c56 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
1.2 KB
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #DEP:linux_src |
---|
8 | |
---|
9 | #Loose build-dependencies |
---|
10 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
11 | #(not recommended) |
---|
12 | ##NEED:doxygen |
---|
13 | |
---|
14 | #######Essential package info. |
---|
15 | #Change these if autodetection fails. |
---|
16 | |
---|
17 | #Name of the Syn-3 package that we are going to create |
---|
18 | NAME=ifenslave |
---|
19 | |
---|
20 | #Version of the sourcefiles |
---|
21 | VER=`uname -r|sed 's/-/_/'` |
---|
22 | |
---|
23 | #Architecture that the created binaries run on. |
---|
24 | #Use noarch for scripts. |
---|
25 | ARCH=`uname -m` |
---|
26 | |
---|
27 | #from this point on, exit on errors: |
---|
28 | set -e |
---|
29 | |
---|
30 | ########Build and create the pacakge. |
---|
31 | #Uncomment the stuff that you dont want or need |
---|
32 | |
---|
33 | |
---|
34 | mkdir -p /tmp/pkg/sbin |
---|
35 | gcc -Wall -Wstrict-prototypes -O -I/usr/src/linux/include /usr/src/linux/Documentation/networking/ifenslave.c -o /tmp/pkg/sbin/ifenslave || exit 1 |
---|
36 | chmod 755 /tmp/pkg/sbin/* |
---|
37 | |
---|
38 | |
---|
39 | #strip bins and other stuff |
---|
40 | syn3_strip /tmp/pkg || exit 1 |
---|
41 | |
---|
42 | #make main package |
---|
43 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
44 | |
---|
45 | |
---|
46 | |
---|
Note: See
TracBrowser
for help on using the repository browser.