source: npl/overig/irssi/irssi.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.7 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:glib2
8#DEP:libtermcap
9
10#######Essential package info.
11#Change these if autodetection fails.
12
13#Name of the Syn-3 package that we are going to create
14NAME=`basename $0|sed 's/.SlackBuild//'`
15
16#Archive of the sourcefiles to unpack
17SRC_ARC=`ls *.tar.*`
18
19#Version of the sourcefiles
20VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
21
22#Directory of the sourcefiles to build (after optional unpacking)
23SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
24
25#Architecture that the created binaries run on.
26#Use noarch for scripts.
27ARCH=`arch`
28
29
30########Build and create the pacakge.
31#Uncomment the stuff that you dont want or need
32
33#Unpack source
34#(uncomment if not needed)
35syn3_unpack $SRC_ARC || exit 1
36
37#apply patches
38#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
39
40#build and install sourcefiles
41#(use one of the other syn3_build_* scripts when needed)
42export CONFIGURE_OPTS=""
43export MAKE_OPTS=""
44#export NOTEST=1
45syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
46
47#strip bins and other stuff
48syn3_strip /tmp/pkg || exit 1
49
50#default config
51cp irssi.conf /tmp/pkg/usr/etc || exit 1
52
53#extra scripts
54cp hostcolor.pl /tmp/pkg/usr/share/irssi/scripts || exit 1
55
56#move development stuff and create seperate development package
57syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
58syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
59
60#make main package
61syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
62
63
Note: See TracBrowser for help on using the repository browser.