1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | #DEP:libnl |
---|
14 | |
---|
15 | #Loose build-dependencies |
---|
16 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
17 | #(not recommended) |
---|
18 | ##NEED:doxygen |
---|
19 | |
---|
20 | #######Essential package info. |
---|
21 | #Change these if autodetection fails. |
---|
22 | |
---|
23 | #Name of the Syn-3 package that we are going to create |
---|
24 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
25 | |
---|
26 | #Archive of the sourcefiles to unpack |
---|
27 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
28 | |
---|
29 | #Version of the sourcefiles |
---|
30 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
31 | |
---|
32 | #Architecture that the created binaries run on. |
---|
33 | #Use noarch for scripts. |
---|
34 | ARCH=`uname -m` |
---|
35 | |
---|
36 | #from this point on, exit on errors: |
---|
37 | set -e |
---|
38 | |
---|
39 | ########Build and create the pacakge. |
---|
40 | #Uncomment the stuff that you dont want or need |
---|
41 | |
---|
42 | #Unpack source |
---|
43 | #(uncomment if not needed) |
---|
44 | syn3_unpack $SRC_ARC |
---|
45 | |
---|
46 | #Directory where the sourcefiles are unpacked. |
---|
47 | #(you might have to adjust this if autodetection fails) |
---|
48 | SRC_DIR=`ls -c|head -1` |
---|
49 | |
---|
50 | #apply patches |
---|
51 | #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 |
---|
52 | |
---|
53 | pushd $SRC_DIR |
---|
54 | |
---|
55 | sed 's/.t ..DESTDIR./$(DESTDIR)/g' -i Makefile |
---|
56 | |
---|
57 | |
---|
58 | #AUTOMAKE: Compile |
---|
59 | make $MAKE_OPTS || exit 1 |
---|
60 | |
---|
61 | |
---|
62 | #AUTOMAKE: Install |
---|
63 | mkdir -p /tmp/pkg/usr/man/man8 /tmp/pkg/usr/sbin |
---|
64 | cp iw /tmp/pkg/usr/sbin |
---|
65 | chmod +x /tmp/pkg/usr/sbin/* |
---|
66 | cp iw.8 /tmp/pkg/usr/man/man8 |
---|
67 | |
---|
68 | popd |
---|
69 | |
---|
70 | #make main package |
---|
71 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
72 | |
---|
73 | |
---|
74 | |
---|