source: npl/overig/jsoncpp/jsoncpp.SlackBuild @ c834706

gcc484perl-5.22
Last change on this file since c834706 was 8c2f7e4, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

for kopano

  • Property mode set to 100755
File size: 1.4 KB
RevLine 
[8c2f7e4]1#!/bin/bash
2
3#NEED:cmake
4##DEP:..
5
6#######Essential package info.
7#Change these if autodetection fails.
8
9#Name of the Syn-3 package that we are going to create
10NAME=`basename $0|sed 's/.SlackBuild//'`
11
12#Archive of the sourcefiles to unpack
13SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
14
15#Version of the sourcefiles
16VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
17
18#Architecture that the created binaries run on.
19#Use noarch for scripts.
20ARCH=`uname -m`
21
22#from this point on, exit on errors:
23set -e
24
25########Build and create the pacakge.
26#Uncomment the stuff that you dont want or need
27
28#Unpack source
29#(uncomment if not needed)
30syn3_unpack $SRC_ARC
31
32#Directory where the sourcefiles are unpacked.
33#(you might have to adjust this if autodetection fails)
34SRC_DIR=`ls -c|head -1`
35
36#apply patches
37#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
38
39pushd $SRC_DIR
40
41mkdir -p build
42cd build
43cmake -DCMAKE_BUILD_TYPE=release -DBUILD_STATIC_LIBS=ON -DBUILD_SHARED_LIBS=ON -DARCHIVE_INSTALL_DIR=. -G "Unix Makefiles" .. -DCMAKE_INSTALL_INCLUDEDIR=include/jsoncpp -DCMAKE_INSTALL_PREFIX=/usr
44make
45make install DESTDIR=/tmp/pkg
46
47popd
48
49#strip bins and other stuff
50syn3_strip /tmp/pkg || exit 1
51
52#move development stuff and create seperate development package
53syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
54syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
55
56#make main package
57syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
58
59
60
Note: See TracBrowser for help on using the repository browser.