source: npl/overig/ldns/ldns.SlackBuild @ 4aea2ca

Last change on this file since 4aea2ca was c6da4cb, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

libreswan update to 3.21

  • Property mode set to 100755
File size: 1.8 KB
Line 
1#!/bin/bash
2#DEP:openssl
3##NEED:...
4##DEP:..
5
6#######Essential package info.
7#Change these if autodetection fails.
8
9#Name of the Syn-3 package that we are going to create
10NAME=`basename $0|sed 's/.SlackBuild//'`
11
12#Archive of the sourcefiles to unpack
13SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
14
15#Version of the sourcefiles
16VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
17
18#Architecture that the created binaries run on.
19#Use noarch for scripts.
20ARCH=`uname -m`
21
22#from this point on, exit on errors:
23set -e
24
25########Build and create the pacakge.
26#Uncomment the stuff that you dont want or need
27
28#Unpack source
29#(uncomment if not needed)
30syn3_unpack $SRC_ARC
31
32#Directory where the sourcefiles are unpacked.
33#(you might have to adjust this if autodetection fails)
34SRC_DIR=`ls -c|head -1`
35
36#apply patches
37#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
38
39pushd $SRC_DIR
40
41#AUTOMAKE: Configure
42#Some usefull stuff you sometimes need to set:
43#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
44#export LD_LIBRARY_PATH=/usr/lib/mysql
45#export VPATH=$LD_LIBRARY_PATH
46#export CFLAGS="-std=c89"
47#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
48MAKE_OPTS=""
49./configure --prefix=/usr  || exit 1
50
51#AUTOMAKE: Compile
52make $MAKE_OPTS || exit 1
53
54
55#AUTOMAKE: Install
56mkdir -p /tmp/pkg &>/dev/null
57make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
58popd
59
60#strip bins and other stuff
61syn3_strip /tmp/pkg || exit 1
62
63#move development stuff and create seperate development package
64syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
65syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
66
67#make main package
68syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
69
70
71
Note: See TracBrowser for help on using the repository browser.