source: npl/overig/ledmon/ledmon.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#DEP:sg3_utils
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15#Archive of the sourcefiles to unpack
16SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
17
18#Version of the sourcefiles
19VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
20
21#Architecture that the created binaries run on.
22#Use noarch for scripts.
23ARCH=`uname -m`
24
25#from this point on, exit on errors:
26set -e
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC
34
35#Directory where the sourcefiles are unpacked.
36#(you might have to adjust this if autodetection fails)
37SRC_DIR=`ls -c|head -1`
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41patch -p1 -d $SRC_DIR < types.patch || exit 1
42
43pushd $SRC_DIR
44
45
46#AUTOMAKE: Compile
47make CFLAGS="-fgnu89-inline" || exit 1
48
49#AUTOMAKE: Test (optional)
50if grep ^test: Makefile; then
51        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
52        make $MAKE_OPTS test || exit 1
53elif grep ^check: Makefile; then
54        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
55        make $MAKE_OPTS check || exit 1
56fi
57
58#AUTOMAKE: Install
59mkdir -p /tmp/pkg &>/dev/null
60make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
61popd
62
63#strip bins and other stuff
64syn3_strip /tmp/pkg || exit 1
65
66#move development stuff and create seperate development package
67syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
68syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
69
70#make main package
71syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
72
73
74
Note: See TracBrowser for help on using the repository browser.