source: npl/overig/letsencrypt/letsencrypt.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.4 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15
16#Archive of the sourcefiles to unpack
17SRC_ARC=`ls *.tar.* *zip`
18
19#Version of the sourcefiles
20VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
21#VER=master
22
23#Directory of the sourcefiles to build (after optional unpacking)
24SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
25#SRC_DIR=letsencrypt-master
26
27#Architecture that the created binaries run on.
28#Use noarch for scripts.
29ARCH=`uname -m`
30
31
32########Build and create the pacakge.
33#Uncomment the stuff that you dont want or need
34
35#Unpack source
36#(uncomment if not needed)
37syn3_unpack $SRC_ARC || exit 1
38
39#apply patches
40#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
41
42pushd $SRC_DIR || exit 1
43python setup.py install --root=/tmp/pkg || exit 1
44
45cd acme
46python setup.py install --root=/tmp/pkg || exit 1
47
48popd
49
50
51
52#strip bins and other stuff
53syn3_strip /tmp/pkg || exit 1
54
55#move development stuff and create seperate development package
56syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
57syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
58
59#make main package
60syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
61
62
Note: See TracBrowser for help on using the repository browser.