source: npl/overig/libical/libical.SlackBuild @ 2154c77

Last change on this file since 2154c77 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.5 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21
22#######Essential package info.
23#Change these if autodetection fails.
24
25#Name of the Syn-3 package that we are going to create
26NAME=`basename $0|sed 's/.SlackBuild//'`
27
28#Archive of the sourcefiles to unpack
29SRC_ARC=`ls *.tar.*`
30
31#Version of the sourcefiles
32VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
33
34#Directory of the sourcefiles to build (after optional unpacking)
35SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
36
37#Architecture that the created binaries run on.
38#Use noarch for scripts.
39ARCH=`uname -m`
40
41
42########Build and create the pacakge.
43#Uncomment the stuff that you dont want or need
44
45#Unpack source
46#(uncomment if not needed)
47syn3_unpack $SRC_ARC || exit 1
48
49#apply patches
50#patch -p1 -d $SRC_DIR < libical-0.23-zarafa.patch || exit 1
51patch -p1 -d $SRC_DIR < libical-byday-loop.diff || exit 1
52patch -p1 -d $SRC_DIR < libical-configure-undef-fatal-errors.diff || exit 1
53patch -p1 -d $SRC_DIR < libical-event-outside-timezone-def.diff || exit 1
54patch -p1 -d $SRC_DIR < libical-nth-recur-overflow.diff || exit 1
55patch -p1 -d $SRC_DIR < libical-win32-add-generated-files.diff || exit 1
56patch -p1 -d $SRC_DIR < libical-win32-fix-compile-errors.diff || exit 1
57
58
59#patch -p1 -d $SRC_DIR < libical-0.23-zarafa.patch || exit 1
60
61#build and install sourcefiles
62#./configure optiones:
63export CONFIGURE_OPTS=""
64#options for all make commands:
65export MAKE_OPTS="-j1"
66#skip testing:
67export NOTEST=1
68#extra optiones for the make install command, use with INSTALL_BASE for example:
69export INSTALL_OPTS=""
70syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
71
72#strip bins and other stuff
73syn3_strip /tmp/pkg || exit 1
74
75#move development stuff and create seperate development package
76syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
77syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
78
79#make main package
80syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
81
82
Note: See TracBrowser for help on using the repository browser.