Last change
on this file since 2154c77 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
1.2 KB
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | # http://registrationcenter-download.intel.com/akdlm/irc_nas/1326/l_ipp_ia32_p_6.0.1.071.tar.gz |
---|
| 3 | # rpm2targz gebruiken op de grote intel-ipp60071ia32-6.0p-071.noarch.rpm die in deze targz zit. |
---|
| 4 | # je krijgt dan intel-ipp60071ia32-6.0p-071.noarch.tar.gz |
---|
| 5 | |
---|
| 6 | |
---|
| 7 | #######Essential package info. |
---|
| 8 | #Change these if autodetection fails. |
---|
| 9 | |
---|
| 10 | #Name of the Syn-3 package that we are going to create |
---|
| 11 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
| 12 | |
---|
| 13 | #Archive of the sourcefiles to unpack |
---|
| 14 | SRC_ARC=intel-ipp60071ia32-6.0p-071.noarch.tar.gz |
---|
| 15 | |
---|
| 16 | #Version of the sourcefiles |
---|
| 17 | VER=6.0p |
---|
| 18 | |
---|
| 19 | #Architecture that the created binaries run on. |
---|
| 20 | #Use noarch for scripts. |
---|
| 21 | ARCH=noarch |
---|
| 22 | |
---|
| 23 | #from this point on, exit on errors: |
---|
| 24 | set -e |
---|
| 25 | |
---|
| 26 | ########Build and create the pacakge. |
---|
| 27 | #Uncomment the stuff that you dont want or need |
---|
| 28 | |
---|
| 29 | #Unpack source |
---|
| 30 | #(uncomment if not needed) |
---|
| 31 | syn3_unpack $SRC_ARC |
---|
| 32 | |
---|
| 33 | |
---|
| 34 | mkdir -p /tmp/pkg |
---|
| 35 | mv opt /tmp/pkg |
---|
| 36 | |
---|
| 37 | #strip bins and other stuff |
---|
| 38 | syn3_strip /tmp/pkg || exit 1 |
---|
| 39 | |
---|
| 40 | #move development stuff and create seperate development package |
---|
| 41 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
| 42 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
| 43 | |
---|
| 44 | #make main package |
---|
| 45 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
| 46 | |
---|
| 47 | |
---|
| 48 | |
---|
Note: See
TracBrowser
for help on using the repository browser.