source: npl/overig/librpcsecgss/librpcsecgss.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11#DEP:libgssglue
12
13#######Essential package info.
14#Change these if autodetection fails.
15
16#Name of the Syn-3 package that we are going to create
17NAME=`basename $0|sed 's/.SlackBuild//'`
18
19#Archive of the sourcefiles to unpack
20SRC_ARC=`ls *.tar.*`
21
22#Version of the sourcefiles
23VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
24
25#Directory of the sourcefiles to build (after optional unpacking)
26SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
27
28#Architecture that the created binaries run on.
29#Use noarch for scripts.
30ARCH=`arch`
31
32
33########Build and create the pacakge.
34#Uncomment the stuff that you dont want or need
35
36#Unpack source
37#(uncomment if not needed)
38syn3_unpack $SRC_ARC || exit 1
39
40#apply patches
41#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
42
43#build and install sourcefiles
44#./configure optiones:
45export CONFIGURE_OPTS=""
46#options for all make commands:
47export MAKE_OPTS=""
48#skip testing:
49#export NOTEST=1
50#extra optiones for the make install command, use with INSTALL_BASE for example:
51export INSTALL_OPTS=""
52syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
53
54#strip bins and other stuff
55syn3_strip /tmp/pkg || exit 1
56
57#move development stuff and create seperate development package
58syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
59syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
60
61#make main package
62syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
63
64
Note: See TracBrowser for help on using the repository browser.