Last change
on this file since 26ffad7 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
401 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | #DEP:bzip2 |
---|
| 3 | #DEP:zlib |
---|
| 4 | #DEP:popt |
---|
| 5 | |
---|
| 6 | NAME=librsync |
---|
| 7 | VER=0.9.7 |
---|
| 8 | CWD=`pwd` |
---|
| 9 | PKGTMP=/tmp/pkgtmp |
---|
| 10 | |
---|
| 11 | mkdir -p $PKGTMP &>/dev/null |
---|
| 12 | |
---|
| 13 | tar -xzf $NAME-$VER.tar.gz || exit 1 |
---|
| 14 | |
---|
| 15 | cd $NAME-$VER |
---|
| 16 | ./configure --prefix=/usr || exit 1 |
---|
| 17 | make || exit 1 |
---|
| 18 | make DESTDIR=$PKGTMP install || exit 1 |
---|
| 19 | |
---|
| 20 | cd "$PKGTMP" || exit 1 |
---|
| 21 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 22 | echo $VER > $CWD/$NAME.version && |
---|
| 23 | arch > $CWD/$NAME.arch |
---|
| 24 | |
---|
Note: See
TracBrowser
for help on using the repository browser.