source: npl/overig/libtiff/libtiff.SlackBuild @ 94ad01e

perl-5.22
Last change on this file since 94ad01e was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.8 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11##DEP:glib
12
13#Loose build-dependencies.
14#Use this to specify the packages that are required to build our package:
15##NEED:libcairo
16##NEED:xorg_proto
17##NEED:xorg_lib
18#DEP:libjpeg
19
20#######Essential package info.
21#Change these if autodetection fails.
22
23#Name of the Syn-3 package that we are going to create
24NAME=`basename $0|sed 's/.SlackBuild//'`
25
26#Archive of the sourcefiles to unpack
27SRC_ARC=`ls *.tar.gz`
28
29#Version of the sourcefiles
30VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/.tar.gz//g'`
31
32#Directory of the sourcefiles to build (after optional unpacking)
33SRC_DIR=`echo $SRC_ARC| sed 's/.tar.gz//g'`
34
35#Architecture that the created binaries run on.
36#Use noarch for scripts.
37ARCH=`arch`
38
39
40########Build and create the pacakge.
41#Uncomment the stuff that you dont want or need
42
43#Unpack source
44#(uncomment if not needed)
45syn3_unpack $SRC_ARC || exit 1
46
47#build and install sourcefiles
48#(use one of the other syn3_build_* scripts when needed)
49export CONFIGURE_OPTS="--with-docdir='/tmp"
50export MAKE_OPTS=""
51#export NOTEST=1
52syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
53
54#strip bins and other stuff
55syn3_strip /tmp/pkg || exit 1
56
57#move development stuff and create seperate development package
58syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
59syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
60
61#make main package
62syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
63
64
Note: See TracBrowser for help on using the repository browser.