source: npl/overig/libtool/libtool.SlackBuild.orig @ 8c2f7e4

gcc484perl-5.22
Last change on this file since 8c2f7e4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.1 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2013, 2015  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23VERSION=${VERSION:-$(echo libtool-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
24BUILD=${BUILD:-4}
25
26NUMJOBS=${NUMJOBS:--j6}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38CWD=$(pwd)
39TMP=${TMP:-/tmp}
40PKG=$TMP/package-libtool
41
42if [ "$ARCH" = "i586" ]; then
43  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "i686" ]; then
46  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
47  LIBDIRSUFFIX=""
48elif [ "$ARCH" = "x86_64" ]; then
49  SLKCFLAGS="-O2 -fPIC"
50  LIBDIRSUFFIX="64"
51else
52  SLKCFLAGS="-O2"
53  LIBDIRSUFFIX=""
54fi
55
56rm -rf $PKG
57mkdir -p $TMP $PKG
58cd $TMP
59rm -rf libtool-$VERSION
60
61tar xvf $CWD/libtool-$VERSION.tar.xz || exit 1
62
63cd libtool-$VERSION
64chown -R root:root .
65find . \
66 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67 -exec chmod 755 {} \; -o \
68 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69 -exec chmod 644 {} \;
70
71zcat $CWD/libtool.no.moved.warning.diff.gz | patch -p1 --verbose || exit 1
72
73CFLAGS="$SLKCFLAGS" \
74./configure \
75  --prefix=/usr \
76  --libdir=/usr/lib${LIBDIRSUFFIX} \
77  --infodir=/usr/info \
78  --mandir=/usr/man \
79  --docdir=/usr/doc/libtool-$VERSION \
80  --build=$ARCH-slackware-linux || exit 1
81
82make $NUMJOBS || make || exit 1
83make install DESTDIR=$PKG || exit 1
84
85find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
86  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
87
88gzip -9 $PKG/usr/man/man?/*.?
89
90rm -f $PKG/usr/info/dir
91gzip -9 $PKG/usr/info/*
92
93mkdir -p $PKG/usr/doc/libtool-$VERSION
94cp -a \
95  AUTHORS COPYING* NEWS README* THANKS TODO \
96    $PKG/usr/doc/libtool-$VERSION
97
98mkdir $PKG/install
99zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
100cat $CWD/slack-desc > $PKG/install/slack-desc
101
102cd $PKG
103/sbin/makepkg -l y -c n $TMP/libtool-${VERSION}-$ARCH-$BUILD.txz
104
Note: See TracBrowser for help on using the repository browser.