1 | #!/bin/bash |
---|
2 | #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild |
---|
3 | #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. |
---|
4 | #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. |
---|
5 | ##################################### Build dependency info: |
---|
6 | |
---|
7 | #Strict build-dependencies |
---|
8 | #Our package will be automaticly rebuilded if there is a major change in a DEP package. |
---|
9 | #(this is recommended for most dependencys) |
---|
10 | ##DEP:linux |
---|
11 | ##DEP:linux_src |
---|
12 | ##DEP:openldap |
---|
13 | |
---|
14 | #Loose build-dependencies |
---|
15 | #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. |
---|
16 | #(not recommended) |
---|
17 | ##DEP:doxygen |
---|
18 | |
---|
19 | |
---|
20 | #######Essential package info. |
---|
21 | #Change these if autodetection fails. |
---|
22 | |
---|
23 | #Name of the Syn-3 package that we are going to create |
---|
24 | NAME=`basename $0|sed 's/.SlackBuild//'` |
---|
25 | |
---|
26 | #Archive of the sourcefiles to unpack |
---|
27 | SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` |
---|
28 | |
---|
29 | #Version of the sourcefiles |
---|
30 | VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` |
---|
31 | |
---|
32 | #Architecture that the created binaries run on. |
---|
33 | #Use noarch for scripts. |
---|
34 | ARCH=`uname -m` |
---|
35 | |
---|
36 | ########Build and create the pacakge. |
---|
37 | #Uncomment the stuff that you dont want or need |
---|
38 | |
---|
39 | #Unpack source |
---|
40 | #(uncomment if not needed) |
---|
41 | syn3_unpack $SRC_ARC || exit 1 |
---|
42 | |
---|
43 | #Directory where the sourcefiles are unpacked. |
---|
44 | #(you might have to adjust this if autodetection fails) |
---|
45 | SRC_DIR=`ls -c|head -1` |
---|
46 | |
---|
47 | pushd $SRC_DIR || exit 1 |
---|
48 | make -j1 E="@echo" RANLIB=ranlib AR=ar Q=@ prefix=/usr DESTDIR=/tmp/pkg || exit 1 |
---|
49 | make -j1 E="@echo" RANLIB=ranlib AR=ar Q=@ prefix=/usr DESTDIR=/tmp/pkg install || exit 1 |
---|
50 | rm /tmp/pkg/usr/lib/libvolume_id.so.0 |
---|
51 | /usr/bin/install -c -m 755 -D libvolume_id.so.0 /tmp/pkg/usr/lib/libvolume_id.so.0 || exit 1 |
---|
52 | popd |
---|
53 | |
---|
54 | #strip bins and other stuff |
---|
55 | syn3_strip /tmp/pkg || exit 1 |
---|
56 | |
---|
57 | #move development stuff and create seperate development package |
---|
58 | syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 |
---|
59 | syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 |
---|
60 | |
---|
61 | #make main package |
---|
62 | syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 |
---|
63 | |
---|
64 | |
---|