source: npl/overig/libxml2/libxml2.SlackBuild.orig @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.6 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=libxml2
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-2}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i586" ]; then
41  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-libxml2
57rm -rf $PKG
58mkdir -p $TMP $PKG
59
60cd $TMP
61rm -rf libxml2-$VERSION
62tar xvf $CWD/libxml2-$VERSION.tar.?z* || exit 1
63cd libxml2-$VERSION
64chown -R root:root .
65find . \
66  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67  -exec chmod 755 {} \; -o \
68  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69  -exec chmod 644 {} \;
70
71zcat $CWD/libxml2.do-not-check-crc.diff.gz | patch -p1 --verbose || exit 1
72
73zcat $CWD/0001-Fix-attribute-decoding-during-XML-schema-validation.diff.gz | patch -p1 --verbose || exit 1
74
75CFLAGS="$SLKCFLAGS" \
76./configure \
77  --prefix=/usr \
78  --libdir=/usr/lib${LIBDIRSUFFIX} \
79  --mandir=/usr/man \
80  --disable-static \
81  --build=$ARCH-slackware-linux
82
83make $NUMJOBS || make || exit 1
84make install DESTDIR=$PKG || exit 1
85
86#echo
87#echo "Only the python bindings in /usr/lib/python__/site-packages/ should"
88#echo "be kept... toss the other stuff"
89#echo
90
91find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
92  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
93
94mv $PKG/usr/share/doc $PKG/usr
95mv $PKG/usr/doc/libxml2-python-$VERSION $PKG/usr/doc/libxml2-$VERSION
96cp -a \
97  AUTHORS COPYING* INSTALL NEWS README \
98  $PKG/usr/doc/libxml2-$VERSION
99find $PKG/usr/doc/libxml2-$VERSION -type f | xargs chmod 644
100
101gzip -9 $PKG/usr/man/man?/*.?
102
103mkdir -p $PKG/install
104cat $CWD/slack-desc > $PKG/install/slack-desc
105# Be sure to clobber any .pyc files that might have been generated so that
106# the new .py files will be used instead of the already compiled copies
107cat << EOF > $PKG/install/doinst.sh
108rm -f /usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/libxml2.pyc
109rm -f /usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/drv_libxml2.pyc
110EOF
111
112cd $PKG
113/sbin/makepkg -l y -c n $TMP/libxml2-$VERSION-$ARCH-$BUILD.txz
114
Note: See TracBrowser for help on using the repository browser.