source: npl/overig/libxslt/libxslt.SlackBuild.orig @ ac00c8f

Last change on this file since ac00c8f was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.1 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2012, 2013, 2016  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23PKGNAM=libxslt
24VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27# Automatically determine the architecture we're building on:
28if [ -z "$ARCH" ]; then
29  case "$( uname -m )" in
30    i?86) export ARCH=i586 ;;
31    arm*) export ARCH=arm ;;
32    # Unless $ARCH is already set, use uname -m for all other archs:
33       *) export ARCH=$( uname -m ) ;;
34  esac
35fi
36
37NUMJOBS=${NUMJOBS:-" -j7 "}
38
39if [ "$ARCH" = "i586" ]; then
40  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
41  LIBDIRSUFFIX=""
42elif [ "$ARCH" = "s390" ]; then
43  SLKCFLAGS="-O2"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "x86_64" ]; then
46  SLKCFLAGS="-O2 -fPIC"
47  LIBDIRSUFFIX="64"
48fi
49
50CWD=$(pwd)
51TMP=${TMP:-/tmp}
52PKG=$TMP/package-libxslt
53rm -rf $PKG
54mkdir -p $TMP $PKG
55
56cd $TMP
57rm -rf libxslt-$VERSION
58tar xvf $CWD/libxslt-$VERSION.tar.?z* || exit 1
59cd libxslt-$VERSION
60chown -R root:root .
61find . \
62  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
63  -exec chmod 755 {} \; -o \
64  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
65  -exec chmod 644 {} \;
66
67CFLAGS="$SLKCFLAGS" \
68./configure \
69  --prefix=/usr \
70  --libdir=/usr/lib${LIBDIRSUFFIX} \
71  --mandir=/usr/man \
72  --disable-static \
73  --build=$ARCH-slackware-linux
74
75make $NUMJOBS || make || exit 1
76make install DESTDIR=$PKG || exit 1
77
78mv $PKG/usr/share/doc $PKG/usr
79#mv $PKG/usr/doc/libxslt-python-$VERSION $PKG/usr/doc/libxslt-$VERSION
80cp -a \
81  AUTHORS COPYING* Copyright FEATURES INSTALL NEWS README TODO libxslt.spec \
82  $PKG/usr/doc/libxslt-$VERSION
83find $PKG/usr/doc/libxslt-$VERSION -type f | xargs chmod 644
84
85find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
86  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
87
88gzip -9 $PKG/usr/man/man?/*.?
89
90mkdir -p $PKG/install
91cat $CWD/slack-desc > $PKG/install/slack-desc
92
93#echo
94#echo "Only the python bindings in /usr/lib/python__/site-packages/ should"
95#echo "be kept... toss the other stuff"
96#echo
97
98cd $PKG
99/sbin/makepkg -l y -c n $TMP/libxslt-$VERSION-$ARCH-$BUILD.txz
100
Note: See TracBrowser for help on using the repository browser.