source: npl/overig/libyajl/libyajl.SlackBuild @ 51c3d1a

perl-5.22
Last change on this file since 51c3d1a was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.4 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#NEED:ruby
8#NEED:cmake
9
10#######Essential package info.
11#Change these if autodetection fails.
12
13#Name of the Syn-3 package that we are going to create
14NAME=`basename $0|sed 's/.SlackBuild//'`
15
16#Archive of the sourcefiles to unpack
17SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
18
19#Version of the sourcefiles
20VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
21
22#Architecture that the created binaries run on.
23#Use noarch for scripts.
24ARCH=`uname -m`
25
26#from this point on, exit on errors:
27set -e
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC
35
36#Directory where the sourcefiles are unpacked.
37#(you might have to adjust this if autodetection fails)
38SRC_DIR=`ls -c|head -1`
39
40#apply patches
41#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
42
43pushd $SRC_DIR
44
45#AUTOMAKE: Configure
46#Some usefull stuff you sometimes need to set:
47#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
48#export LD_LIBRARY_PATH=/usr/lib/mysql
49#export VPATH=$LD_LIBRARY_PATH
50#export CFLAGS="-std=c89"
51export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
52MAKE_OPTS=""
53./configure --prefix=/usr  || exit 1
54
55#AUTOMAKE: Compile
56make $MAKE_OPTS || exit 1
57
58#AUTOMAKE: Test (optional)
59if grep ^test: Makefile; then
60        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
61        make $MAKE_OPTS test || exit 1
62elif grep ^check: Makefile; then
63        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
64        make $MAKE_OPTS check || exit 1
65fi
66
67#AUTOMAKE: Install
68mkdir -p /tmp/pkg &>/dev/null
69make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
70popd
71
72#strip bins and other stuff
73syn3_strip /tmp/pkg || exit 1
74
75#move development stuff and create seperate development package
76syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
77syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
78
79#make main package
80syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
81
82
83
Note: See TracBrowser for help on using the repository browser.