source: npl/overig/linuxdoc_tools/linuxdoc_tools.SlackBuild @ 105afb5

Last change on this file since 105afb5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 956 bytes
Line 
1#!/bin/bash
2#
3# Automaticly created by importpackage v1.0
4# Imported from: http://mirrors.slackware.com/slackware/slackware-current/source/ap/linuxdoc-tools/
5# Created at Sat Dec 12 13:46:41 CET 2015
6
7#NEED:slacktrack
8#NEED:rpm
9#DEP:flex
10#NEED:groff
11#DEP:libxml2
12#DEP:libxslt
13#DEP:intltool
14#DEP:itstool
15
16set -e
17
18########### source original slackbuild (hopefully we dont need to modify it)
19CWD=`pwd`
20source ./trackbuild.linuxdoc-tools
21
22ARCH=`arch`
23VERSION=$PKGVERSION
24############ make syn3 packages
25cd $CWD
26rm /tmp/build-linuxdoc-tools/makepkg.tmppkg/linuxdoc_tools.SlackBuild.log
27for PKG in /tmp/build-linuxdoc-tools/makepkg.tmppkg; do
28        #NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'`
29        NAME=linuxdoc_tools
30
31        #seperate dev-package
32        syn3_move_dev $PKG $PKG""_dev
33        syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
34
35        #make main package
36        syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
37done
Note: See TracBrowser for help on using the repository browser.