source: npl/overig/lrmi/lrmi.SlackBuild @ c6da4cb

gcc484perl-5.22
Last change on this file since c6da4cb was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 520 bytes
Line 
1#!/bin/bash
2
3NAME=lrmi
4VER=0.10
5CWD=`pwd`
6PKGTMP=/tmp/pkgtmp
7
8mkdir -p $PKGTMP &>/dev/null
9
10tar -xzf $NAME-$VER.tar.gz || exit 1
11
12cd $NAME-$VER || exit 1
13make || exit 1
14
15LIBDIR=$PKGTMP/usr/lib
16INCDIR=$PKGTMP/usr/include
17mkdir -p $LIBDIR $INCDIR || exit 1
18#EDWIN broken:
19#make LIBDIR=$LIBDIR INCDIR=$INCDIR install || exit 1
20cp -a liblrmi* $LIBDIR || exit 1
21cp -a lrmi.h $INCDIR || exit 1
22
23cd "$PKGTMP" || exit 1
24makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
25echo $VER > $CWD/$NAME.version &&
26arch > $CWD/$NAME.arch
27
Note: See TracBrowser for help on using the repository browser.