[c5c522c] | 1 | #!/bin/sh |
---|
| 2 | |
---|
| 3 | # Copyright 2008, 2009, 2010, 2011, 2013 Patrick J. Volkerding, Sebeka, MN, USA |
---|
| 4 | # All rights reserved. |
---|
| 5 | # |
---|
| 6 | # Redistribution and use of this script, with or without modification, is |
---|
| 7 | # permitted provided that the following conditions are met: |
---|
| 8 | # |
---|
| 9 | # 1. Redistributions of this script must retain the above copyright |
---|
| 10 | # notice, this list of conditions and the following disclaimer. |
---|
| 11 | # |
---|
| 12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
| 13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
| 14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
| 15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
| 16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
| 17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
| 18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
| 19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
| 20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
| 21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
| 22 | |
---|
| 23 | |
---|
| 24 | VERSION=${VERSION:-$(echo mc-*.tar.?z* | cut -d - -f 2 | rev | cut -f 3- -d . | rev)} |
---|
| 25 | BUILD=${BUILD:-2} |
---|
| 26 | |
---|
| 27 | # Automatically determine the architecture we're building on: |
---|
| 28 | if [ -z "$ARCH" ]; then |
---|
| 29 | case "$( uname -m )" in |
---|
| 30 | i?86) export ARCH=i486 ;; |
---|
| 31 | arm*) export ARCH=arm ;; |
---|
| 32 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
| 33 | *) export ARCH=$( uname -m ) ;; |
---|
| 34 | esac |
---|
| 35 | fi |
---|
| 36 | |
---|
| 37 | NUMJOBS=${NUMJOBS:-" -j7 "} |
---|
| 38 | |
---|
| 39 | if [ "$ARCH" = "i486" ]; then |
---|
| 40 | SLKCFLAGS="-O2 -march=i486 -mtune=i686" |
---|
| 41 | elif [ "$ARCH" = "s390" ]; then |
---|
| 42 | SLKCFLAGS="-O2" |
---|
| 43 | elif [ "$ARCH" = "x86_64" ]; then |
---|
| 44 | SLKCFLAGS="-O2 -fPIC" |
---|
| 45 | else |
---|
| 46 | SLKCFLAGS="-O2" |
---|
| 47 | fi |
---|
| 48 | |
---|
| 49 | CWD=$(pwd) |
---|
| 50 | TMP=${TMP:-/tmp} |
---|
| 51 | PKG=$TMP/package-mc |
---|
| 52 | rm -rf $PKG |
---|
| 53 | mkdir -p $TMP $PKG/usr |
---|
| 54 | |
---|
| 55 | cd $TMP |
---|
| 56 | rm -rf mc-$VERSION |
---|
| 57 | tar xvf $CWD/mc-$VERSION.tar.xz || exit 1 |
---|
| 58 | cd mc-$VERSION || exit 1 |
---|
| 59 | |
---|
| 60 | chown -R root:root . |
---|
| 61 | find . \ |
---|
| 62 | \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ |
---|
| 63 | -exec chmod 755 {} \; -o \ |
---|
| 64 | \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ |
---|
| 65 | -exec chmod 644 {} \; |
---|
| 66 | |
---|
| 67 | # Use geeqie instead of gqview as an external image viewer: |
---|
| 68 | zcat $CWD/mc.image.sh.geeqie.diff.gz | patch -p1 --verbose || exit 1 |
---|
| 69 | |
---|
| 70 | # Upstream bugfix for crash moving directories: |
---|
| 71 | zcat $CWD/changeset_54a5139eec69438f8771ffddcff96a2e72a197ff.diff.gz | patch -p0 --verbose || exit 1 |
---|
| 72 | |
---|
| 73 | # Upstream fix for cmdline directory handling: |
---|
| 74 | zcat $CWD/changeset_446748619b5cb77ea63360a81bb16cd2dd2caff7.diff.gz | patch -p0 --verbose || exit 1 |
---|
| 75 | |
---|
| 76 | if [ ! -x ./configure ]; then |
---|
| 77 | ./autogen.sh |
---|
| 78 | fi |
---|
| 79 | |
---|
| 80 | CFLAGS="$SLKCFLAGS" \ |
---|
| 81 | ./configure \ |
---|
| 82 | --prefix=/usr \ |
---|
| 83 | --sysconfdir=/etc \ |
---|
| 84 | --mandir=/usr/man \ |
---|
| 85 | --localstatedir=/var \ |
---|
| 86 | --docdir=/usr/doc/mc-$VERSION \ |
---|
| 87 | --enable-extcharset \ |
---|
| 88 | --enable-netcode \ |
---|
| 89 | --enable-background \ |
---|
| 90 | --enable-charset \ |
---|
| 91 | --with-gpm-mouse \ |
---|
| 92 | --with-ext2undel \ |
---|
| 93 | --with-x=yes \ |
---|
| 94 | --with-vfs \ |
---|
| 95 | --enable-vfs-smb \ |
---|
| 96 | --with-smb-configdir=/etc/samba \ |
---|
| 97 | --with-smb-codepagedir=/etc/codepages \ |
---|
| 98 | --build=$ARCH-slackware-linux || exit 1 |
---|
| 99 | |
---|
| 100 | make $NUMJOBS || make || exit 1 |
---|
| 101 | make DESTDIR=$PKG install || exit 1 |
---|
| 102 | |
---|
| 103 | find $PKG | xargs file | grep -e "executable" -e "shared object" \ |
---|
| 104 | | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
| 105 | |
---|
| 106 | mkdir -p $PKG/usr/share/mc/bin |
---|
| 107 | cp -a $CWD/profile.d/mc-wrapper.* $PKG/usr/share/mc/bin |
---|
| 108 | chown root:root $PKG/usr/share/mc/bin/* |
---|
| 109 | chmod 755 $PKG/usr/share/mc/bin/* |
---|
| 110 | |
---|
| 111 | mkdir -p $PKG/etc/profile.d |
---|
| 112 | cp -a $CWD/profile.d/mc.* $PKG/etc/profile.d |
---|
| 113 | chown root:root $PKG/etc/profile.d/* |
---|
| 114 | chmod 755 $PKG/etc/profile.d/* |
---|
| 115 | |
---|
| 116 | # Compress and link manpages, if any: |
---|
| 117 | if [ -d $PKG/usr/man ]; then |
---|
| 118 | ( cd $PKG/usr/man |
---|
| 119 | for manpagedir in $(find . -type d -name "man*") ; do |
---|
| 120 | ( cd $manpagedir |
---|
| 121 | for eachpage in $( find . -type l -maxdepth 1) ; do |
---|
| 122 | ln -s $( readlink $eachpage ).gz $eachpage.gz |
---|
| 123 | rm $eachpage |
---|
| 124 | done |
---|
| 125 | gzip -9 *.? |
---|
| 126 | ) |
---|
| 127 | done |
---|
| 128 | ) |
---|
| 129 | fi |
---|
| 130 | |
---|
| 131 | mkdir -p $PKG/usr/doc/mc-$VERSION |
---|
| 132 | cp -a \ |
---|
| 133 | AUTHORS doc/COPYING* doc/FAQ doc/HACKING doc/INSTALL doc/MAINTAINERS doc/NEWS doc/README* doc/TODO \ |
---|
| 134 | $PKG/usr/doc/mc-$VERSION |
---|
| 135 | |
---|
| 136 | mkdir -p $PKG/install |
---|
| 137 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
| 138 | |
---|
| 139 | cd $PKG |
---|
| 140 | /sbin/makepkg -l y -c n $TMP/mc-$VERSION-$ARCH-$BUILD.txz |
---|
| 141 | |
---|