source: npl/overig/mhash/mhash.SlackBuild.orig @ 929bb42

Last change on this file since 929bb42 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.6 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2011  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=mhash
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-3}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i486 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i486" ]; then
41  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-mhash
57
58rm -rf $PKG
59mkdir -p $TMP $PKG
60cd $TMP
61rm -rf mhash-$VERSION
62tar xvf $CWD/mhash-$VERSION.tar.?z* || exit 1
63cd mhash-$VERSION
64chown -R root:root .
65find . \
66  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67  -exec chmod 755 {} \; -o \
68  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69  -exec chmod 644 {} \;
70
71CFLAGS="$SLKCFLAGS" \
72./configure \
73  --prefix=/usr \
74  --libdir=/usr/lib${LIBDIRSUFFIX} \
75  --mandir=/usr/man \
76  --program-prefix="" \
77  --program-suffix="" \
78  --build=$ARCH-slackware-linux
79
80make $NUMJOBS || make || exit 1
81make install DESTDIR=$PKG || exit 1
82
83# This caused problems.  Leaving it here to serve as a warning.  ;-)
84#
85## Fix mhash.h so that it does not include its own config.h from
86## autoconf, because this will duplicate macros and mess up anything
87## that tries to use autoconf to include mhash.h...
88#sed -i "s,^#define MUTILS_USE_MHASH_CONFIG,/* #define MUTILS_USE_MHASH_CONFIG */,g" $PKG/usr/include/mhash.h
89
90find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
91  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
92
93mkdir -p $PKG/usr/doc/mhash-$VERSION
94cp -a \
95  AUTHORS COPYING* INSTALL NEWS README* THANKS TODO \
96  $PKG/usr/doc/mhash-$VERSION
97
98# If there's a ChangeLog, installing at least part of the recent history
99# is useful, but don't let it get totally out of control:
100if [ -r ChangeLog ]; then
101  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
102  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
103  touch -r ChangeLog $DOCSDIR/ChangeLog
104fi
105
106gzip -9 $PKG/usr/man/man?/*.?
107
108mkdir -p $PKG/install
109cat $CWD/slack-desc > $PKG/install/slack-desc
110
111cd $PKG
112/sbin/makepkg -l y -c n $TMP/mhash-$VERSION-$ARCH-$BUILD.txz
113
Note: See TracBrowser for help on using the repository browser.