source: npl/overig/motion/motion.SlackBuild @ e856512

Last change on this file since e856512 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2
3##NEED:...
4##DEP:..
5#DEP:libjpeg
6#DEP:ffmpeg
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
19
20#Architecture that the created binaries run on.
21#Use noarch for scripts.
22ARCH=`uname -m`
23
24#from this point on, exit on errors:
25set -e
26
27########Build and create the pacakge.
28#Uncomment the stuff that you dont want or need
29
30#Unpack source
31#(uncomment if not needed)
32syn3_unpack $SRC_ARC
33
34#Directory where the sourcefiles are unpacked.
35#(you might have to adjust this if autodetection fails)
36SRC_DIR=`ls -c|head -1`
37
38#apply patches
39#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
40
41pushd $SRC_DIR
42
43#AUTOMAKE: Configure
44#Some usefull stuff you sometimes need to set:
45#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
46#export LD_LIBRARY_PATH=/usr/lib/mysql
47#export VPATH=$LD_LIBRARY_PATH
48#export CFLAGS="-std=c89"
49#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
50MAKE_OPTS=""
51autoreconf -fiv || exit 1
52
53./configure --prefix=/usr  || exit 1
54
55#AUTOMAKE: Compile
56make $MAKE_OPTS || exit 1
57
58#AUTOMAKE: Test (optional)
59if grep ^test: Makefile; then
60        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
61        make $MAKE_OPTS test || exit 1
62elif grep ^check: Makefile; then
63        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
64        make $MAKE_OPTS check || exit 1
65fi
66
67#AUTOMAKE: Install
68mkdir -p /tmp/pkg &>/dev/null
69make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
70popd
71
72#strip bins and other stuff
73syn3_strip /tmp/pkg || exit 1
74
75#move development stuff and create seperate development package
76syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
77syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
78
79#make main package
80syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
81
82
83
Note: See TracBrowser for help on using the repository browser.