gcc484ntopperl-5.22
Last change
on this file since c5c522c was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
830 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | |
---|
3 | NAME=ntp |
---|
4 | VER=4.2.8p4 |
---|
5 | CWD=`pwd` |
---|
6 | PKGTMP=/tmp/pkgtmp |
---|
7 | |
---|
8 | mkdir -p $PKGTMP &>/dev/null |
---|
9 | |
---|
10 | mkdir $PKGTMP/etc |
---|
11 | cp $CWD/ntp.conf $PKGTMP/etc || exit 1 |
---|
12 | |
---|
13 | mkdir -p $PKGTMP/service/ntp || exit 1 |
---|
14 | cp $CWD/run $PKGTMP/service/ntp || exit 1 |
---|
15 | chmod +x $PKGTMP/service/ntp/run || exit 1 |
---|
16 | |
---|
17 | mkdir -p $PKGTMP/etc/postinst.d || exit 1 |
---|
18 | cp $CWD/post.10_ntp $PKGTMP/etc/postinst.d || exit 1 |
---|
19 | chmod +x $PKGTMP/etc/postinst.d/* || exit 1 |
---|
20 | |
---|
21 | tar -xzf *.tar.gz || exit 1 |
---|
22 | |
---|
23 | #export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html |
---|
24 | |
---|
25 | cd $NAME-$VER || exit 1 |
---|
26 | ./configure --prefix=/usr --bindir=/usr/sbin || exit 1 |
---|
27 | make || exit 1 |
---|
28 | make DESTDIR=$PKGTMP install || exit 1 |
---|
29 | |
---|
30 | cd "$PKGTMP" || exit 1 |
---|
31 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
32 | echo $VER > $CWD/$NAME.version && |
---|
33 | arch > $CWD/$NAME.arch |
---|
34 | |
---|
Note: See
TracBrowser
for help on using the repository browser.