source: npl/overig/ntp/ntp.SlackBuild @ c5c522c

gcc484ntopperl-5.22
Last change on this file since c5c522c was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 830 bytes
Line 
1#!/bin/bash
2
3NAME=ntp
4VER=4.2.8p4
5CWD=`pwd`
6PKGTMP=/tmp/pkgtmp
7
8mkdir -p $PKGTMP &>/dev/null
9
10mkdir $PKGTMP/etc
11cp $CWD/ntp.conf $PKGTMP/etc || exit 1
12
13mkdir -p $PKGTMP/service/ntp || exit 1
14cp $CWD/run $PKGTMP/service/ntp || exit 1
15chmod +x $PKGTMP/service/ntp/run || exit 1
16
17mkdir -p $PKGTMP/etc/postinst.d || exit 1
18cp $CWD/post.10_ntp $PKGTMP/etc/postinst.d || exit 1
19chmod +x $PKGTMP/etc/postinst.d/* || exit 1
20
21tar -xzf *.tar.gz || exit 1
22
23#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
24
25cd $NAME-$VER || exit 1
26./configure --prefix=/usr --bindir=/usr/sbin || exit 1
27make || exit 1
28make DESTDIR=$PKGTMP install || exit 1
29
30cd "$PKGTMP" || exit 1
31makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
32echo $VER > $CWD/$NAME.version &&
33arch > $CWD/$NAME.arch
34
Note: See TracBrowser for help on using the repository browser.