Last change
on this file was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
523 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | |
---|
3 | NAME=ocaml |
---|
4 | VERSION=3.12.1 |
---|
5 | CWD=`pwd` |
---|
6 | TMP="/tmp" |
---|
7 | PKGTMP="$TMP/pkgtmp" |
---|
8 | mkdir $PKGTMP &>/dev/null |
---|
9 | |
---|
10 | tar -xjf $NAME-$VERSION.tar.bz2 || exit 1 |
---|
11 | cd $NAME-$VERSION || exit 1 |
---|
12 | # ./setup.py install --root $PKGTMP || exit 1 |
---|
13 | ./configure --prefix /usr || exit 1 |
---|
14 | make -j1 world || exit 1 |
---|
15 | make -j1 bootstrap || exit 1 |
---|
16 | make -j1 opt || exit 1 |
---|
17 | make -j1 opt.opt || exit 1 |
---|
18 | make -j1 PREFIX=/tmp/pkgtmp/usr install || exit 1 |
---|
19 | |
---|
20 | cd $PKGTMP |
---|
21 | makepkg -l y -c n $CWD/$NAME.pkg |
---|
22 | echo $VERSION > $CWD/$NAME.version && |
---|
23 | arch > $CWD/$NAME.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.