source: npl/overig/ocaml/ocaml.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 523 bytes
Line 
1#!/bin/bash
2
3NAME=ocaml
4VERSION=3.12.1
5CWD=`pwd`
6TMP="/tmp"
7PKGTMP="$TMP/pkgtmp"
8mkdir $PKGTMP &>/dev/null
9
10tar -xjf $NAME-$VERSION.tar.bz2 || exit 1
11cd $NAME-$VERSION || exit  1
12# ./setup.py install --root $PKGTMP || exit 1
13./configure --prefix /usr || exit 1
14make -j1 world || exit 1
15make -j1 bootstrap || exit 1
16make -j1 opt || exit 1
17make -j1 opt.opt || exit 1
18make -j1 PREFIX=/tmp/pkgtmp/usr install || exit 1
19
20cd $PKGTMP
21makepkg -l y -c n $CWD/$NAME.pkg
22echo $VERSION > $CWD/$NAME.version &&
23arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.