source: npl/overig/po4a/po4a.SlackBuild @ a9c55d3

perl-5.22
Last change on this file since a9c55d3 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.1 KB
Line 
1#!/bin/bash
2#DEP:perlmod_Module_Build
3#DEP:gettext
4
5#######Essential package info.
6#Change these if autodetection fails.
7
8#Name of the Syn-3 package that we are going to create
9NAME=`basename $0|sed 's/.SlackBuild//'`
10
11#Archive of the sourcefiles to unpack
12SRC_ARC=`ls *.tar.*`
13
14#Version of the sourcefiles
15VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
16
17#Directory of the sourcefiles to build (after optional unpacking)
18SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
19
20#Architecture that the created binaries run on.
21#Use noarch for scripts.
22ARCH=`uname -m`
23
24
25########Build and create the pacakge.
26#Uncomment the stuff that you dont want or need
27
28#Unpack source
29#(uncomment if not needed)
30syn3_unpack $SRC_ARC || exit 1
31
32#apply patches
33#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
34
35pushd $SRC_DIR
36make || exit 1
37make install DESTDIR=/tmp/pkg  || exit 1
38popd
39
40#strip bins and other stuff
41syn3_strip /tmp/pkg || exit 1
42
43#move development stuff and create seperate development package
44syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
45syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
46
47#make main package
48syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
49
50
Note: See TracBrowser for help on using the repository browser.