source: npl/overig/powertop/powertop.SlackBuild.orig @ 1393bb5

gcc484ntopperl-5.22
Last change on this file since 1393bb5 was 1393bb5, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

added powertop

  • Property mode set to 100755
File size: 4.0 KB
RevLine 
[1393bb5]1#!/bin/sh
2
3# Copyright 2010, 2012  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23# Modified by Willy Sudiarto Raharjo
24# Changelog
25# May, 11 : Bumped to 2.0, Fix compilation process, Added patch to fix complaints about a file
26# May, 18 : Rebuilt, removed non-existence directory for man pages
27
28PKGNAM=powertop
29VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
30BUILD=${BUILD:-2}
31
32# Automatically determine the architecture we're building on:
33if [ -z "$ARCH" ]; then
34  case "$( uname -m )" in
35    i?86) export ARCH=i586 ;;
36    arm*) export ARCH=arm ;;
37    # Unless $ARCH is already set, use uname -m for all other archs:
38       *) export ARCH=$( uname -m ) ;;
39  esac
40fi
41
42NUMJOBS=${NUMJOBS:-" -j7 "}
43
44CWD=$(pwd)
45TMP=${TMP:-/tmp}
46PKG=$TMP/package-${PKGNAM}
47rm -rf $PKG
48mkdir -p $TMP $PKG
49
50if [ "$ARCH" = "i586" ]; then
51  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
52  LIBDIRSUFFIX=""
53elif [ "$ARCH" = "s390" ]; then
54  SLKCFLAGS="-O2"
55  LIBDIRSUFFIX=""
56elif [ "$ARCH" = "x86_64" ]; then
57  SLKCFLAGS="-O2 -fPIC"
58  LIBDIRSUFFIX="64"
59else
60  SLKCFLAGS="-O2"
61  LIBDIRSUFFIX=""
62fi
63
64cd $TMP
65rm -rf ${PKGNAM}-${VERSION}
66tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
67cd ${PKGNAM}-$VERSION || exit 1
68
69# Make sure ownerships and permissions are sane:
70chown -R root:root .
71find . \
72  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
73  -exec chmod 755 {} \; -o \
74  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
75  -exec chmod 644 {} \;
76
77LDFLAGS=" -lresolv -lz " \
78CFLAGS="$SLKCFLAGS" \
79CXXFLAGS="$SLKCFLAGS" \
80./configure \
81  --prefix=/usr \
82  --libdir=/usr/lib${LIBDIRSUFFIX} \
83  --sysconfdir=/etc \
84  --localstatedir=/var \
85  --mandir=/usr/man \
86  --docdir=/usr/doc/$PRGNAM-$VERSION \
87  --build=$ARCH-slackware-linux || exit 1
88
89# Build and install:
90make $NUMJOBS || make || exit 1
91make install DESTDIR=$PKG || exit 1
92
93# Strip binaries:
94find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
95  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
96
97# Compress and if needed symlink the man pages:
98if [ -d $PKG/usr/man ]; then
99  ( cd $PKG/usr/man
100    for manpagedir in $(find . -type d -name "man*") ; do
101      ( cd $manpagedir
102        for eachpage in $( find . -type l -maxdepth 1) ; do
103          ln -s $( readlink $eachpage ).gz $eachpage.gz
104          rm $eachpage
105        done
106        gzip -9 *.?
107      )
108    done
109  )
110fi
111
112# Add a documentation directory:
113mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
114cp -a \
115  COPYING* README* TODO \
116  $PKG/usr/doc/${PKGNAM}-$VERSION
117
118# If there's a ChangeLog, installing at least part of the recent history
119# is useful, but don't let it get totally out of control:
120if [ -r ChangeLog ]; then
121  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
122  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
123  touch -r ChangeLog $DOCSDIR/ChangeLog
124fi
125
126mkdir -p $PKG/install
127cat $CWD/slack-desc > $PKG/install/slack-desc
128
129cd $PKG
130/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
131
Note: See TracBrowser for help on using the repository browser.