source: npl/overig/readline/readline.SlackBuild.orig @ 072d3d5

gcc484perl-5.22
Last change on this file since 072d3d5 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.5 KB
Line 
1#!/bin/sh
2
3# Copyright 2005-2015  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=readline
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-2}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40CWD=$(pwd)
41TMP=${TMP:-/tmp}
42PKG=$TMP/package-readline
43
44if [ "$ARCH" = "i586" ]; then
45  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
46  LIBDIRSUFFIX=""
47elif [ "$ARCH" = "s390" ]; then
48  SLKCFLAGS="-O2"
49  LIBDIRSUFFIX=""
50elif [ "$ARCH" = "x86_64" ]; then
51  SLKCFLAGS="-O2 -fPIC"
52  LIBDIRSUFFIX="64"
53else
54  SLKCFLAGS="-O2"
55  LIBDIRSUFFIX=""
56fi
57
58rm -rf $PKG
59mkdir -p $TMP $PKG
60
61cd $TMP
62rm -rf readline-$VERSION
63tar xvf $CWD/readline-$VERSION.tar.?z* || exit 1
64cd readline-$VERSION || exit 1
65chown -R root:root .
66find . \
67  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
68  -exec chmod 755 {} \; -o \
69  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
70  -exec chmod 644 {} \;
71
72for file in $CWD/readline-*-patches/readline*-??? ; do
73  cat $file | patch -p0 --verbose || exit 1
74done
75
76CFLAGS="$SLKCFLAGS" \
77./configure \
78  --prefix=/usr \
79  --libdir=/usr/lib${LIBDIRSUFFIX} \
80  --mandir=/usr/man \
81  --infodir=/usr/info \
82  --docdir=/usr/doc/readline-$VERSION \
83  --with-curses \
84  --enable-multibyte \
85  --disable-static \
86  --build=$ARCH-slackware-linux-gnu || exit 1
87
88make $NUMJOBS static shared || make static shared || exit 1
89make install DESTDIR=$PKG || exit 1
90
91find $PKG | xargs file | grep -e "executable" -e "shared object" \
92  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
93
94# Compress manual pages:
95find $PKG/usr/man -type f -exec gzip -9 {} \;
96for i in $( find $PKG/usr/man -type l ) ; do
97  ln -s $( readlink $i ).gz $i.gz
98  rm $i
99done
100
101# Compress info files, if any:
102if [ -d $PKG/usr/info ]; then
103  ( cd $PKG/usr/info
104    rm -f dir
105    gzip -9 *
106  )
107fi
108
109chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/lib*.so.*
110
111mkdir -p $PKG/usr/doc/readline-$VERSION
112cp -a \
113  CHANGELOG CHANGES COPYING* INSTALL MANIFEST README* USAGE \
114  $PKG/usr/doc/readline-$VERSION
115
116mkdir -p $PKG/install
117cat $CWD/slack-desc > $PKG/install/slack-desc
118
119# Build the package:
120cd $PKG
121/sbin/makepkg -l y -c n $TMP/readline-$VERSION-$ARCH-$BUILD.txz
122
Note: See TracBrowser for help on using the repository browser.