source: npl/overig/splashutils/splashutils.SlackBuild @ 8c2f7e4

gcc484perl-5.22
Last change on this file since 8c2f7e4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#SPLASHUTILS NEEDS AT LEAST BINUTILS 2.18!
3
4##DEP:klibc
5#DEP:libjpeg
6#DEP:freetype2
7#DEP:bzip2
8#DEP:zlib
9
10#######Essential package info.
11#Change these if autodetection fails.
12
13#Name of the Syn-3 package that we are going to create
14NAME=`basename $0|sed 's/.SlackBuild//'`
15
16#Archive of the sourcefiles to unpack
17SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
18
19#Version of the sourcefiles
20VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
21
22#Architecture that the created binaries run on.
23#Use noarch for scripts.
24ARCH=`uname -m`
25
26#from this point on, exit on errors:
27set -e
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC
35
36#Directory where the sourcefiles are unpacked.
37#(you might have to adjust this if autodetection fails)
38SRC_DIR=`ls -c|head -1`
39
40#apply patches
41#patch -p2 -d $SRC_DIR < splashutils-1.5.4.3-makefile.patch || exit 1
42
43pushd $SRC_DIR
44
45#AUTOMAKE: Configure
46#Some usefull stuff you sometimes need to set:
47#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
48#export LD_LIBRARY_PATH=/usr/lib/mysql
49#export VPATH=$LD_LIBRARY_PATH
50MAKE_OPTS=""
51./configure --enable-static --prefix=/usr --without-gpm --without-png --with-ttf --with-ttf-kernel --without-klibc   || exit 1
52
53
54#AUTOMAKE: Compile
55make $MAKE_OPTS || exit 1
56
57#AUTOMAKE: Install
58mkdir -p /tmp/pkg &>/dev/null
59make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
60popd
61
62#tweaks
63#mv /tmp/pkg/usr/bin/splash_util /tmp/pkg/sbin || exit 1
64mkdir -p /tmp/pkg/lib/splash/cache || exit 1
65
66#strip bins and other stuff
67syn3_strip /tmp/pkg || exit 1
68
69#move development stuff and create seperate development package
70syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
71syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
72
73#make main package
74syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
75
76
77
Note: See TracBrowser for help on using the repository browser.