Last change
on this file since ac00c8f was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
848 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/sh |
---|
| 2 | |
---|
| 3 | CWD=`pwd` |
---|
| 4 | PACKAGENAME="ssmtp" |
---|
| 5 | VERSION="2.50.6.1" |
---|
| 6 | PACKAGETEMP="$CWD/temp" |
---|
| 7 | |
---|
| 8 | tar zxf "$PACKAGENAME"_"$VERSION".tar.gz || exit 1 |
---|
| 9 | cd "$PACKAGENAME"-"$VERSION" |
---|
| 10 | ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var || exit 1 |
---|
| 11 | make || exit 1 |
---|
| 12 | |
---|
| 13 | # copy die rommel in een packageroot |
---|
| 14 | mkdir -p "$PACKAGETEMP/usr/"{sbin,man/man8} |
---|
| 15 | mkdir -p "$PACKAGETEMP/etc/ssmtp" |
---|
| 16 | cp ssmtp "$PACKAGETEMP/usr/sbin/" || exit 1 |
---|
| 17 | cp ssmtp.8 "$PACKAGETEMP/usr/man/man8/" || exit 1 |
---|
| 18 | cp "$CWD/revaliases" "$PACKAGETEMP/etc/ssmtp" || exit 1 |
---|
| 19 | cp "$CWD/ssmtp.conf" "$PACKAGETEMP/etc/ssmtp" || exit 1 |
---|
| 20 | cd "$PACKAGETEMP/usr/sbin" |
---|
| 21 | ln -s ssmtp sendmail || exit 1 |
---|
| 22 | cd "$PACKAGETEMP/usr/man/man8" |
---|
| 23 | ln -s ssmtp.8 sendmail.8 || exit 1 |
---|
| 24 | |
---|
| 25 | cd $PACKAGETEMP |
---|
| 26 | makepkg -l y -c n $CWD/$PACKAGENAME.pkg > /dev/null && |
---|
| 27 | echo $VERSION > $CWD/$PACKAGENAME.version && |
---|
| 28 | arch > $CWD/$PACKAGENAME.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.