source: npl/overig/stress/stress.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 571 bytes
Line 
1#!/bin/bash
2
3NAME=stress
4VER=0.18.8
5CWD=`pwd`
6PKGTMP=/tmp/pkgtmp
7TARNAME=$NAME
8
9mkdir -p $PKGTMP &>/dev/null
10
11tar -xzf $TARNAME-$VER.tar.gz || exit 1
12
13cd $TARNAME-$VER || exit 1
14./configure --prefix=/usr --sysconfdir=/etc || exit 1
15make || exit 1
16#make test || exit 1
17make INSTALL_PREFIX=$PKGTMP DESTDIR=$PKGTMP install || exit 1
18
19
20mkdir -p $PKGTMP/usr/bin
21cp $CWD/syn3-stress $PKGTMP/usr/bin
22chmod +x $PKGTMP/usr/bin/syn3-stress || exit 1
23
24cd "$PKGTMP" || exit 1
25makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
26echo $VER > $CWD/$NAME.version &&
27arch > $CWD/$NAME.arch
28
Note: See TracBrowser for help on using the repository browser.