source: npl/overig/texinfo/texinfo.SlackBuild.orig @ 9e573a2

Last change on this file since 9e573a2 was a9c55d3, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

texinfo update

  • Property mode set to 100755
File size: 3.6 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2016  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=texinfo
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-2}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i586 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38NUMJOBS=${NUMJOBS:-" -j7 "}
39
40if [ "$ARCH" = "i586" ]; then
41  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "i686" ]; then
44  SLKCFLAGS="-O2 -march=i686"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "s390" ]; then
47  SLKCFLAGS="-O2"
48  LIBDIRSUFFIX=""
49elif [ "$ARCH" = "x86_64" ]; then
50  SLKCFLAGS="-O2 -fPIC"
51  LIBDIRSUFFIX="64"
52elif [ "$ARCH" = "armv7hl" ]; then
53  SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16"
54  LIBDIRSUFFIX=""
55else
56  SLKCFLAGS="-O2"
57  LIBDIRSUFFIX=""
58fi
59
60CWD=$(pwd)
61TMP=${TMP:-/tmp}
62PKG=$TMP/package-texinfo
63
64rm -rf $PKG
65mkdir -p $TMP $PKG
66
67cd $TMP
68tar xvf $CWD/texinfo-$VERSION.tar.xz || exit 1
69cd texinfo-$VERSION
70find . \
71 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
72 -exec chmod 755 {} \; -o \
73 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
74 -exec chmod 644 {} \;
75
76CFLAGS="$SLKCFLAGS" \
77./configure \
78  --prefix=/usr \
79  --sysconfdir=/etc \
80  --libdir=/usr/lib${LIBDIRSUFFIX} \
81  --mandir=/usr/man \
82  --infodir=/usr/info \
83  --disable-static \
84  --docdir=/usr/doc/texinfo-$VERSION \
85  --build=$ARCH-slackware-linux || exit 1
86
87make $NUMJOBS || make || exit 1
88make install DESTDIR=$PKG
89
90# Be sure this is "fresh"
91zcat $CWD/dir.gz > $PKG/usr/info/dir
92mv $PKG/usr/info/dir $PKG/usr/info/dir.new
93
94gzip -9 $PKG/usr/info/*info*
95gzip -9 $PKG/usr/man/man?/*
96
97mkdir -p $PKG/usr/doc/texinfo-$VERSION
98cp -a \
99  ABOUT-NLS AUTHORS COPYING* INSTALL NEWS README* TODO \
100  $PKG/usr/doc/texinfo-$VERSION
101chmod 644 $PKG/usr/doc/texinfo-$VERSION/*
102chown -R root:root $PKG/usr/doc/texinfo-$VERSION
103
104# If there's a ChangeLog, installing at least part of the recent history
105# is useful, but don't let it get totally out of control:
106if [ -r ChangeLog ]; then
107  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
108  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
109  touch -r ChangeLog $DOCSDIR/ChangeLog
110fi
111
112mkdir -p $PKG/install
113cat $CWD/slack-desc > $PKG/install/slack-desc
114zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
115
116# Build the package:
117cd $PKG
118/sbin/makepkg -l y -c n $TMP/texinfo-$VERSION-$ARCH-$BUILD.txz
119
Note: See TracBrowser for help on using the repository browser.