source: npl/overig/texinfo/texinfo.SlackBuild @ 4e011a4

gcc484perl-5.22
Last change on this file since 4e011a4 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.9 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:glib_dev
17##NEED:gtk+
18##NEED:gtk+_dev
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:ncurses
22
23#######Essential package info.
24#Change these if autodetection fails.
25
26#Name of the Syn-3 package that we are going to create
27NAME=`basename $0|sed 's/.SlackBuild//'`
28
29#Archive of the sourcefiles to unpack
30SRC_ARC=`ls *.tar.*`
31
32#Version of the sourcefiles
33VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
34
35
36#Directory of the sourcefiles to build (after optional unpacking)
37#SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
38SRC_DIR=texinfo-4.8
39
40#Architecture that the created binaries run on.
41#Use noarch for scripts.
42ARCH=`arch`
43
44
45########Build and create the pacakge.
46#Uncomment the stuff that you dont want or need
47
48#Unpack source
49#(uncomment if not needed)
50syn3_unpack $SRC_ARC || exit 1
51
52#apply patches
53#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
54
55#build and install sourcefiles
56#(use one of the other syn3_build_* scripts when needed)
57export CONFIGURE_OPTS=""
58export MAKE_OPTS=""
59#export NOTEST=1
60syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
61
62#strip bins and other stuff
63syn3_strip /tmp/pkg || exit 1
64
65#move development stuff and create seperate development package
66syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
67syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
68
69#make main package
70syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
71
72
Note: See TracBrowser for help on using the repository browser.