source: npl/overig/unison/unison.SlackBuild @ c834706

gcc484perl-5.22
Last change on this file since c834706 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.6 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#NEED:ocaml
8#NEED:ctags
9
10#######Essential package info.
11#Change these if autodetection fails.
12
13#Name of the Syn-3 package that we are going to create
14NAME=`basename $0|sed 's/.SlackBuild//'`
15
16#Archive of the sourcefiles to unpack
17SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
18
19#Version of the sourcefiles
20VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
21
22#Architecture that the created binaries run on.
23#Use noarch for scripts.
24ARCH=`uname -m`
25
26#from this point on, exit on errors:
27set -e
28
29########Build and create the pacakge.
30#Uncomment the stuff that you dont want or need
31
32#Unpack source
33#(uncomment if not needed)
34syn3_unpack $SRC_ARC
35
36#Directory where the sourcefiles are unpacked.
37#(you might have to adjust this if autodetection fails)
38SRC_DIR=`ls -c|head -1`
39
40#apply patches
41#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
42
43pushd $SRC_DIR
44
45
46#AUTOMAKE: Compile
47make UISTYLE=text || exit 1
48
49#AUTOMAKE: Install
50mkdir -p /tmp/pkg/bin &>/dev/null
51make INSTALLDIR=/tmp/pkg/bin/ install || exit 1
52popd
53
54
55#strip bins and other stuff
56syn3_strip /tmp/pkg || exit 1
57
58#move development stuff and create seperate development package
59syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
60syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
61
62#make main package
63syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
64
65
66
Note: See TracBrowser for help on using the repository browser.