source: npl/overig/utempter/utempter.SlackBuild.orig @ 26ffad7

Last change on this file since 26ffad7 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.7 KB
Line 
1#!/bin/sh
2
3# Copyright 2008-2010, 2015, 2016  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23# The original package name was "utempter", but this new version
24# calls itself "libutempter".  We'll keep the same old package name
25# to avoid confusing upgrades.
26
27VERSION=1.1.6
28BUILD=${BUILD:-2}
29
30# Automatically determine the architecture we're building on:
31if [ -z "$ARCH" ]; then
32  case "$( uname -m )" in
33    i?86) export ARCH=i586 ;;
34    arm*) export ARCH=arm ;;
35    # Unless $ARCH is already set, use uname -m for all other archs:
36       *) export ARCH=$( uname -m ) ;;
37  esac
38fi
39
40if [ "$ARCH" = "i586" ]; then
41  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
42  LIBDIRSUFFIX=""
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45  LIBDIRSUFFIX=""
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48  LIBDIRSUFFIX="64"
49else
50  SLKCFLAGS="-O2"
51  LIBDIRSUFFIX=""
52fi
53
54CWD=$(pwd)
55TMP=${TMP:-/tmp}
56PKG=$TMP/package-utempter
57
58rm -rf $PKG
59mkdir -p $TMP $PKG/usr
60cd $TMP
61rm -rf libutempter-$VERSION
62tar xvf $CWD/libutempter-$VERSION.tar.bz2
63cd libutempter-$VERSION
64chown -R root:root .
65find . \
66  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67  -exec chmod 755 {} \; -o \
68  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69  -exec chmod 644 {} \;
70
71# Fix libdir for x86_64:
72sed -i -e "s#/usr/lib#/usr/lib${LIBDIRSUFFIX}#g" Makefile
73
74make RPM_OPT_FLAGS="$SLKCFLAGS" mandir=/usr/man
75make install mandir=/usr/man DESTDIR=$PKG
76
77# A static libutempter seems like a bad idea, since it wouldn't work without
78# the making utempter binary. That and the shared lib are a closely matched set.
79rm -f $PKG/usr/lib${LIBDIRSUFFIX}/libutempter.a
80
81# Ensure proper ownership and permissions:
82chown root:utmp $PKG/usr/lib${LIBDIRSUFFIX}/utempter/utempter
83chmod 2755 $PKG/usr/lib${LIBDIRSUFFIX}/utempter/utempter
84
85# Compress and link manpages, if any:
86if [ -d $PKG/usr/man ]; then
87  ( cd $PKG/usr/man
88    for manpagedir in $(find . -type d -name "man*") ; do
89      ( cd $manpagedir
90        for eachpage in $( find . -type l -maxdepth 1 | grep -v '\.gz$') ; do
91          ln -s $( readlink $eachpage ).gz $eachpage.gz
92          rm $eachpage
93        done
94        gzip -9 *.?
95      )
96    done
97  )
98fi
99
100mkdir -p $PKG/usr/doc/utempter-$VERSION
101cp -a \
102  COPYING README \
103  $PKG/usr/doc/utempter-$VERSION
104
105( cd $PKG
106  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
107  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
108)
109
110mkdir -p $PKG/install
111cat $CWD/slack-desc > $PKG/install/slack-desc
112zcat $CWD/doinst.sh > $PKG/install/doinst.sh
113
114cd $PKG
115/sbin/makepkg -l y -c n $TMP/utempter-$VERSION-$ARCH-$BUILD.txz
116
Note: See TracBrowser for help on using the repository browser.