source: npl/overig/wget/wget.SlackBuild.orig @ d0ec78d

gcc484perl-5.22
Last change on this file since d0ec78d was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 3.3 KB
Line 
1#!/bin/sh
2
3# Copyright 2008, 2009, 2010, 2012, 2013, 2014, 2015  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24VERSION=${VERSION:-$(echo wget-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
25BUILD=${BUILD:-1}
26
27NUMJOBS=${NUMJOBS:-" -j7 "}
28
29# Automatically determine the architecture we're building on:
30if [ -z "$ARCH" ]; then
31  case "$( uname -m )" in
32    i?86) export ARCH=i586 ;;
33    arm*) export ARCH=arm ;;
34    # Unless $ARCH is already set, use uname -m for all other archs:
35       *) export ARCH=$( uname -m ) ;;
36  esac
37fi
38
39if [ "$ARCH" = "i386" ]; then
40  SLKCFLAGS="-O2 -march=i386 -mtune=i686"
41elif [ "$ARCH" = "i586" ]; then
42  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
43elif [ "$ARCH" = "s390" ]; then
44  SLKCFLAGS="-O2"
45elif [ "$ARCH" = "x86_64" ]; then
46  SLKCFLAGS="-O2 -fPIC"
47else
48  SLKCFLAGS="-O2"
49fi
50
51CWD=$(pwd)
52TMP=${TMP:-/tmp}
53PKG=$TMP/package-wget
54
55rm -rf $PKG
56mkdir -p $TMP $PKG
57cd $TMP
58rm -rf wget-$VERSION
59tar xvf $CWD/wget-$VERSION.tar.xz || exit 1
60cd wget-$VERSION
61
62chown -R root:root .
63find . \
64 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
65 -exec chmod 755 {} \; -o \
66 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
67 -exec chmod 644 {} \;
68
69CFLAGS="$SLKCFLAGS" \
70./configure  \
71  --prefix=/usr \
72  --sysconfdir=/etc \
73  --mandir=/usr/man \
74  --infodir=/usr/info \
75  --docdir=/usr/doc/wget-$VERSION \
76  --with-ssl=openssl \
77  --build=${ARCH}-slackware-linux || exit 1
78
79make $NUMJOBS || make || exit 1
80make install DESTDIR=$PKG || exit 1
81
82mv $PKG/etc/wgetrc $PKG/etc/wgetrc.new
83
84find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
85  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
86
87rm -f $PKG/usr/info/dir
88gzip -9 $PKG/usr/info/* $PKG/usr/man/man?/*
89
90mkdir -p $PKG/usr/doc/wget-$VERSION
91cp -a \
92  AUTHORS COPYING* MAILING-LIST NEWS README*  \
93  $PKG/usr/doc/wget-$VERSION
94
95# If there's a ChangeLog, installing at least part of the recent history
96# is useful, but don't let it get totally out of control:
97if [ -r ChangeLog ]; then
98  DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
99  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
100  touch -r ChangeLog $DOCSDIR/ChangeLog
101fi
102
103mkdir -p $PKG/install
104cat $CWD/slack-desc > $PKG/install/slack-desc
105zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
106
107cd $PKG
108/sbin/makepkg -l y -c n $TMP/wget-$VERSION-$ARCH-$BUILD.txz
109
Note: See TracBrowser for help on using the repository browser.