1 | #!/bin/sh |
---|
2 | |
---|
3 | # Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA |
---|
4 | # All rights reserved. |
---|
5 | # |
---|
6 | # Redistribution and use of this script, with or without modification, is |
---|
7 | # permitted provided that the following conditions are met: |
---|
8 | # |
---|
9 | # 1. Redistributions of this script must retain the above copyright |
---|
10 | # notice, this list of conditions and the following disclaimer. |
---|
11 | # |
---|
12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
22 | |
---|
23 | |
---|
24 | VERSION=2.20 |
---|
25 | BUILD=${BUILD:-1} |
---|
26 | |
---|
27 | # Automatically determine the architecture we're building on: |
---|
28 | if [ -z "$ARCH" ]; then |
---|
29 | case "$( uname -m )" in |
---|
30 | i?86) export ARCH=i486 ;; |
---|
31 | arm*) export ARCH=arm ;; |
---|
32 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
33 | *) export ARCH=$( uname -m ) ;; |
---|
34 | esac |
---|
35 | fi |
---|
36 | |
---|
37 | CWD=$(pwd) |
---|
38 | TMP=${TMP:-/tmp} |
---|
39 | PKG=$TMP/package-which |
---|
40 | |
---|
41 | rm -rf $PKG |
---|
42 | mkdir -p $TMP $PKG |
---|
43 | |
---|
44 | cd $TMP |
---|
45 | rm -rf which-$VERSION |
---|
46 | tar xvf $CWD/which-$VERSION.tar.gz || exit 1 |
---|
47 | cd which-$VERSION |
---|
48 | |
---|
49 | chown -R root:root . |
---|
50 | find . \ |
---|
51 | \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ |
---|
52 | -exec chmod 755 {} \; -o \ |
---|
53 | \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ |
---|
54 | -exec chmod 644 {} \; |
---|
55 | |
---|
56 | CFLAGS=-O2 \ |
---|
57 | ./configure \ |
---|
58 | --prefix=/usr \ |
---|
59 | --infodir=/usr/info \ |
---|
60 | --mandir=/usr/man \ |
---|
61 | --build=$ARCH-slackware-linux |
---|
62 | |
---|
63 | make || exit 1 |
---|
64 | make install DESTDIR=$PKG || exit 1 |
---|
65 | |
---|
66 | mkdir $PKG/bin |
---|
67 | mv $PKG/usr/bin/which $PKG/bin |
---|
68 | ( cd $PKG/usr/bin ; ln -sf ../../bin/which which ) |
---|
69 | |
---|
70 | # Compress and link manpages, if any: |
---|
71 | if [ -d $PKG/usr/man ]; then |
---|
72 | ( cd $PKG/usr/man |
---|
73 | for manpagedir in $(find . -type d -name "man*") ; do |
---|
74 | ( cd $manpagedir |
---|
75 | for eachpage in $( find . -type l -maxdepth 1) ; do |
---|
76 | ln -s $( readlink $eachpage ).gz $eachpage.gz |
---|
77 | rm $eachpage |
---|
78 | done |
---|
79 | gzip -9 *.? |
---|
80 | ) |
---|
81 | done |
---|
82 | ) |
---|
83 | fi |
---|
84 | |
---|
85 | # Compress info files, if any: |
---|
86 | if [ -d $PKG/usr/info ]; then |
---|
87 | ( cd $PKG/usr/info |
---|
88 | rm -f dir |
---|
89 | gzip -9 * |
---|
90 | ) |
---|
91 | fi |
---|
92 | |
---|
93 | mkdir -p $PKG/usr/doc/which-$VERSION |
---|
94 | cp -a \ |
---|
95 | AUTHORS COPYING EXAMPLES NEWS README README.alias \ |
---|
96 | $PKG/usr/doc/which-$VERSION |
---|
97 | |
---|
98 | # Strip everything for good measure: |
---|
99 | find $PKG | xargs file | grep -e "executable" -e "shared object" \ |
---|
100 | | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null |
---|
101 | |
---|
102 | mkdir -p $PKG/install |
---|
103 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
104 | |
---|
105 | # Build the package: |
---|
106 | cd $PKG |
---|
107 | /sbin/makepkg -l y -c n $TMP/which-$VERSION-$ARCH-$BUILD.txz |
---|
108 | |
---|