source: npl/overig/zlib/zlib.SlackBuild.orig

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.0 KB
Line 
1#!/bin/sh
2
3# Copyright 2005-2012  Patrick J. Volkerding, Sebeka, MN, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24PKGNAM=zlib
25VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26BUILD=${BUILD:-1}
27
28# Automatically determine the architecture we're building on:
29if [ -z "$ARCH" ]; then
30  case "$( uname -m )" in
31    i?86) export ARCH=i486 ;;
32    arm*) export ARCH=arm ;;
33    # Unless $ARCH is already set, use uname -m for all other archs:
34       *) export ARCH=$( uname -m ) ;;
35  esac
36fi
37
38CWD=$(pwd)
39TMP=${TMP:-/tmp}
40PKG=$TMP/package-zlib
41
42if [ "$ARCH" = "i386" ]; then
43  SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
44  LIBDIRSUFFIX=""
45elif [ "$ARCH" = "i486" ]; then
46  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
47  LIBDIRSUFFIX=""
48elif [ "$ARCH" = "s390" ]; then
49  SLKCFLAGS="-O2"
50  LIBDIRSUFFIX=""
51elif [ "$ARCH" = "x86_64" ]; then
52  SLKCFLAGS="-O2 -fPIC"
53  LIBDIRSUFFIX="64"
54else
55  SLKCFLAGS="-O2"
56  LIBDIRSUFFIX=""
57fi
58
59rm -rf $PKG
60mkdir -p $TMP $PKG
61
62cd $TMP
63rm -rf zlib-$VERSION
64tar xvf $CWD/zlib-$VERSION.tar.?z* || exit 1
65cd zlib-$VERSION || exit 1
66
67chown -R root:root .
68find . \
69  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
70  -exec chmod 755 {} \; -o \
71  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
72  -exec chmod 644 {} \;
73
74CFLAGS="$SLKCFLAGS" \
75./configure \
76  --prefix=/usr
77make clean
78make || exit 1
79CFLAGS="$SLKCFLAGS" \
80./configure \
81  --prefix=/usr \
82  --libdir=/usr/lib${LIBDIRSUFFIX} \
83  --shared
84make || exit 1
85
86mkdir -p $PKG/usr/include
87cp -a zlib.h zconf.h $PKG/usr/include
88chmod 644 $PKG/usr/include/*
89mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
90cp -a libz.a libz.so* $PKG/usr/lib${LIBDIRSUFFIX}
91chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/*
92chmod 644 $PKG/usr/lib${LIBDIRSUFFIX}/libz.a
93mkdir -p $PKG/usr/man/man3
94cat zlib.3 | gzip -9c > $PKG/usr/man/man3/zlib.3.gz
95
96# Add pkgconfig file:
97mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
98cat zlib.pc > $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/zlib.pc
99
100# Now that libkmod requires libz, we had better move the shared library
101# up a level:
102mkdir $PKG/lib${LIBDIRSUFFIX}
103( cd $PKG/usr/lib${LIBDIRSUFFIX}
104  for file in lib*.so.?.* ; do
105    mv $file ../../lib${LIBDIRSUFFIX}
106    ln -sf ../../lib${LIBDIRSUFFIX}/$file .
107  done
108  cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
109)
110
111# Strip binaries:
112( cd $PKG
113  #find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
114  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
115)
116
117mkdir -p $PKG/usr/doc/zlib-$VERSION
118cp -a \
119  FAQ INDEX README* \
120  $PKG/usr/doc/zlib-$VERSION
121
122# If there's a ChangeLog, installing at least part of the recent history
123# is useful, but don't let it get totally out of control:
124if [ -r ChangeLog ]; then
125  DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
126  cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
127  touch -r ChangeLog $DOCSDIR/ChangeLog
128fi
129
130mkdir -p $PKG/install
131cat $CWD/slack-desc > $PKG/install/slack-desc
132
133cd $PKG
134makepkg -l y -c n $TMP/zlib-$VERSION-$ARCH-$BUILD.txz
135
Note: See TracBrowser for help on using the repository browser.