source: npl/perl/GDTextUtil/buildmods.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 824 bytes
Line 
1#!/bin/bash
2#DEP:perl
3#DEP:gd
4#DEP:perlmod_GD
5
6#Standaard script voor Syn-3 perlmodules.
7#Dit script build alle perlmodule .tar.gz files in de huidige directory, en maakt
8#er Syn-3 packages van.
9
10CWD=`pwd`
11PKGROOT=`pwd`/pkgtmp
12
13for TAR in *.tar.gz; do
14        TARDIR=`echo $TAR|sed 's/.tar.gz//'` || exit 1
15        VER=`echo $TARDIR|sed 's/.*-//'` || exit 1
16        NAME=perlmod_`echo $TARDIR| sed 's/-[^-]*$//' | sed 's/-/_/'` || exit 1
17       
18        rm -r $PKGROOT 2>/dev/null
19        mkdir -p $PKGROOT
20       
21        #standard way to build a perl module
22        cd $CWD || exit 1
23        export PERL_INSTALL_ROOT=$PKGROOT
24        tar -xzf $TAR || exit 1
25        cd $TARDIR || exit 1
26        perl Makefile.PL || exit 1
27        make || exit 1
28        make test || exit 1
29        make install || exit 1
30       
31        cd $PKGROOT
32        makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
33        echo $VER > $CWD/$NAME.version &&
34        arch > $CWD/$NAME.arch
35done
Note: See TracBrowser for help on using the repository browser.