source: npl/perl/Unicode_MapUTF8/buildmods.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 897 bytes
Line 
1#!/bin/bash
2#DEP:perl
3#DEP:perlmod_Unicode_String
4#DEP:perlmod_Unicode_Map
5#DEP:perlmod_Unicode_Map8
6#DEP:perlmod_Jcode
7
8#Standaard script voor Syn-3 perlmodules.
9#Dit script build alle perlmodule .tar.gz files in de huidige directory, en maakt
10#er Syn-3 packages van.
11
12CWD=`pwd`
13PKGROOT=`pwd`/pkgtmp
14
15for TAR in *.tar.gz; do
16        TARDIR=`echo $TAR|sed 's/.tar.gz//'` || exit 1
17        VER=`echo $TARDIR|sed 's/.*-//'` || exit 1
18        NAME=perlmod_`echo $TARDIR| sed 's/-[^-]*$//' | sed 's/-/_/'` || exit 1
19       
20        rm -r $PKGROOT 2>/dev/null
21        mkdir -p $PKGROOT
22       
23        #standard way to build a perl module
24        cd $CWD || exit 1
25        export PERL_INSTALL_ROOT=$PKGROOT
26        tar -xzf $TAR || exit 1
27        cd $TARDIR || exit 1
28        perl Makefile.PL || exit 1
29        make || exit 1
30        make test || exit 1
31        make install || exit 1
32
33        cd $PKGROOT
34        makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
35        echo $VER > $CWD/$NAME.version &&
36        arch > $CWD/$NAME.arch
37done
Note: See TracBrowser for help on using the repository browser.