source: npl/perl/perl-ldap/buildmods.SlackBuild

Last change on this file was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 930 bytes
Line 
1#!/bin/bash
2#DEP:perl
3#DEP:perlmod_Convert_ASN1
4#DEP:perlmod_Authen_SASL
5#DEP:perlmod_URI
6#DEP:perlmod_IO_Socket_SSL
7#DEP:perlmod_XML_SAX_Base
8
9#Standaard script voor Syn-3 perlmodules.
10#Dit script build alle perlmodule .tar.gz files in de huidige directory, en maakt
11#er Syn-3 packages van.
12
13CWD=`pwd`
14PKGROOT=`pwd`/pkgtmp
15
16for TAR in *.tar.gz; do
17        TARDIR=`echo $TAR|sed 's/.tar.gz//'` || exit 1
18        VER=`echo $TARDIR|sed 's/.*-//'` || exit 1
19        NAME=perlmod_`echo $TARDIR| sed 's/-[^-]*$//' | sed 's/-/_/'` || exit 1
20       
21        rm -r $PKGROOT 2>/dev/null
22        mkdir -p $PKGROOT
23       
24        #standard way to build a perl module
25        cd $CWD || exit 1
26        export PERL_INSTALL_ROOT=$PKGROOT
27        tar -xzf $TAR || exit 1
28        cd $TARDIR || exit 1
29        echo n | perl Makefile.PL || exit 1
30        make || exit 1
31        make test || exit 1
32        make install || exit 1
33       
34        cd $PKGROOT
35        makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
36        echo $VER > $CWD/$NAME.version &&
37        arch > $CWD/$NAME.arch
38done
Note: See TracBrowser for help on using the repository browser.