source: npl/perl/perlmod_Convert_BinHex/perlmod_Convert_BinHex.SlackBuild @ 8662849

perl-5.22
Last change on this file since 8662849 was 8662849, checked in by Edwin Eefting <edwin@datux.nl>, 6 years ago

update/rebuild all perl stuff to 5.22. split up packages

  • Property mode set to 100755
File size: 1.0 KB
Line 
1#!/bin/bash
2#DEP:perl
3#DEP:perlmod_Test_Most
4#DEP:perlmod_Exception_Class
5#DEP:perlmod_Class_Data_Inheritable
6#DEP:perlmod_Devel_StackTrace
7#DEP:perlmod_Test_Deep
8#DEP:perlmod_Test_Exception
9#DEP:perlmod_Test_Differences
10#DEP:perlmod_Text_Diff
11#DEP:perlmod_File_Slurp
12
13#Standaard script voor Syn-3 perlmodules.
14#Dit script build alle perlmodule .tar.gz files in de huidige directory, en maakt
15#er Syn-3 packages van.
16
17CWD=`pwd`
18PKGROOT=`pwd`/pkgtmp
19
20for TAR in *.tar.gz; do
21        TARDIR=`echo $TAR|sed 's/.tar.gz//'` || exit 1
22        VER=`echo $TARDIR|sed 's/.*-//'` || exit 1
23        NAME=perlmod_`echo $TARDIR| sed 's/-[^-]*$//' | sed 's/-/_/g'` || exit 1
24       
25        rm -r $PKGROOT 2>/dev/null
26        mkdir -p $PKGROOT
27       
28        #standard way to build a perl module
29        cd $CWD || exit 1
30        export PERL_INSTALL_ROOT=$PKGROOT
31        tar -xzf $TAR || exit 1
32        cd $TARDIR || exit 1
33        perl Makefile.PL || exit 1
34        make || exit 1
35        make test || exit 1
36        make install || exit 1
37       
38        cd $PKGROOT
39        makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
40        echo $VER > $CWD/$NAME.version &&
41        arch > $CWD/$NAME.arch
42done
Note: See TracBrowser for help on using the repository browser.